Re-introduce (marked as obsolete) mkStrict function, to allow old nixops deployments to keep working.

nixos-19.03
Rob Vermaas 9 years ago
parent 66997bba1e
commit 90a7711e08
  1. 2
      lib/modules.nix

@ -319,6 +319,8 @@ rec {
mkForce = mkOverride 50;
mkVMOverride = mkOverride 10; # used by ‘nixos-rebuild build-vm’
mkStrict = builtins.trace "`mkStrict' is obsolete; use `mkOverride 0' instead." (mkOverride 0);
mkFixStrictness = id; # obsolete, no-op
mkOrder = priority: content:

Loading…
Cancel
Save