Browse Source

pkgs/*: remove unreferenced function arguments

nixos-19.03
volth 4 years ago
parent
commit
52f53c69ce
  1. 4
      pkgs/applications/altcoins/clightning.nix
  2. 2
      pkgs/applications/altcoins/default.nix
  3. 2
      pkgs/applications/altcoins/dero.nix
  4. 2
      pkgs/applications/altcoins/dogecoin.nix
  5. 2
      pkgs/applications/altcoins/ethsign/default.nix
  6. 2
      pkgs/applications/altcoins/freicoin.nix
  7. 2
      pkgs/applications/altcoins/go-ethereum-classic/default.nix
  8. 2
      pkgs/applications/altcoins/go-ethereum.nix
  9. 4
      pkgs/applications/altcoins/hevm.nix
  10. 2
      pkgs/applications/altcoins/mist.nix
  11. 2
      pkgs/applications/altcoins/namecoin.nix
  12. 2
      pkgs/applications/altcoins/nano-wallet/default.nix
  13. 2
      pkgs/applications/altcoins/parity-ui/default.nix
  14. 2
      pkgs/applications/altcoins/parity-ui/env.nix
  15. 3
      pkgs/applications/altcoins/particl/particl-core.nix
  16. 2
      pkgs/applications/altcoins/stellar-core.nix
  17. 4
      pkgs/applications/audio/abcde/default.nix
  18. 2
      pkgs/applications/audio/airwave/default.nix
  19. 4
      pkgs/applications/audio/audacity/default.nix
  20. 2
      pkgs/applications/audio/banshee/default.nix
  21. 2
      pkgs/applications/audio/clementine/default.nix
  22. 2
      pkgs/applications/audio/deadbeef/default.nix
  23. 2
      pkgs/applications/audio/deadbeef/wrapper.nix
  24. 2
      pkgs/applications/audio/distrho/default.nix
  25. 1
      pkgs/applications/audio/faust/faust2.nix
  26. 2
      pkgs/applications/audio/fmit/default.nix
  27. 1
      pkgs/applications/audio/gradio/default.nix
  28. 4
      pkgs/applications/audio/gtkpod/default.nix
  29. 2
      pkgs/applications/audio/jaaa/default.nix
  30. 2
      pkgs/applications/audio/lastfmsubmitd/default.nix
  31. 2
      pkgs/applications/audio/magnetophonDSP/VoiceOfFaust/default.nix
  32. 2
      pkgs/applications/audio/mikmod/default.nix
  33. 2
      pkgs/applications/audio/mopidy/mopify.nix
  34. 2
      pkgs/applications/audio/pianobar/default.nix
  35. 2
      pkgs/applications/audio/picard/default.nix
  36. 2
      pkgs/applications/audio/puddletag/default.nix
  37. 2
      pkgs/applications/audio/puredata/wrapper.nix
  38. 2
      pkgs/applications/audio/rkrlv2/default.nix
  39. 2
      pkgs/applications/audio/sonata/default.nix
  40. 2
      pkgs/applications/audio/ympd/default.nix
  41. 2
      pkgs/applications/backup/crashplan/default.nix
  42. 2
      pkgs/applications/display-managers/lightdm/default.nix
  43. 4
      pkgs/applications/display-managers/sddm/default.nix
  44. 2
      pkgs/applications/editors/android-studio/default.nix
  45. 2
      pkgs/applications/editors/atom/default.nix
  46. 2
      pkgs/applications/editors/atom/env.nix
  47. 4
      pkgs/applications/editors/brackets/default.nix
  48. 2
      pkgs/applications/editors/dit/default.nix
  49. 6
      pkgs/applications/editors/eclipse/default.nix
  50. 2
      pkgs/applications/editors/emacs-modes/emacs-clang-complete-async/default.nix
  51. 2
      pkgs/applications/editors/emacs-modes/filesets-plus/default.nix
  52. 2
      pkgs/applications/editors/emacs-modes/font-lock-plus/default.nix
  53. 2
      pkgs/applications/editors/emacs-modes/header2/default.nix
  54. 2
      pkgs/applications/editors/emacs-modes/hexrgb/default.nix
  55. 2
      pkgs/applications/editors/emacs-modes/lib-requires/default.nix
  56. 2
      pkgs/applications/editors/emacs-modes/melpa-stable-packages.nix
  57. 2
      pkgs/applications/editors/emacs-modes/ocaml/default.nix
  58. 2
      pkgs/applications/editors/emacs-modes/org-packages.nix
  59. 2
      pkgs/applications/editors/emacs-modes/org/default.nix
  60. 2
      pkgs/applications/editors/emacs-modes/thingatpt-plus/default.nix
  61. 2
      pkgs/applications/editors/emacs/25.nix
  62. 2
      pkgs/applications/editors/emacs/default.nix
  63. 4
      pkgs/applications/editors/jetbrains/common.nix
  64. 24
      pkgs/applications/editors/jetbrains/default.nix
  65. 2
      pkgs/applications/editors/jucipp/default.nix
  66. 2
      pkgs/applications/editors/kakoune/default.nix
  67. 2
      pkgs/applications/editors/kodestudio/default.nix
  68. 2
      pkgs/applications/editors/monodevelop/default.nix
  69. 2
      pkgs/applications/editors/nano/default.nix
  70. 4
      pkgs/applications/editors/neovim/default.nix
  71. 5
      pkgs/applications/editors/neovim/wrapper.nix
  72. 2
      pkgs/applications/editors/nvpy/default.nix
  73. 2
      pkgs/applications/editors/texmacs/darwin.nix
  74. 2
      pkgs/applications/editors/tiled/default.nix
  75. 2
      pkgs/applications/editors/typora/default.nix
  76. 2
      pkgs/applications/editors/vim/macvim.nix
  77. 2
      pkgs/applications/editors/vscode/default.nix
  78. 2
      pkgs/applications/editors/vscode/with-extensions.nix
  79. 2
      pkgs/applications/editors/wxhexeditor/default.nix
  80. 2
      pkgs/applications/gis/qgis/default.nix
  81. 4
      pkgs/applications/graphics/ImageMagick/7.0.nix
  82. 2
      pkgs/applications/graphics/ImageMagick/default.nix
  83. 2
      pkgs/applications/graphics/ahoviewer/default.nix
  84. 2
      pkgs/applications/graphics/avocode/default.nix
  85. 2
      pkgs/applications/graphics/awesomebump/default.nix
  86. 3
      pkgs/applications/graphics/digikam/default.nix
  87. 2
      pkgs/applications/graphics/dosage/default.nix
  88. 2
      pkgs/applications/graphics/epeg/default.nix
  89. 2
      pkgs/applications/graphics/fstl/default.nix
  90. 2
      pkgs/applications/graphics/glabels/default.nix
  91. 2
      pkgs/applications/graphics/goxel/default.nix
  92. 2
      pkgs/applications/graphics/graphicsmagick/default.nix
  93. 2
      pkgs/applications/graphics/inkscape/default.nix
  94. 2
      pkgs/applications/graphics/k3d/default.nix
  95. 2
      pkgs/applications/graphics/kgraphviewer/default.nix
  96. 2
      pkgs/applications/graphics/krita/default.nix
  97. 1
      pkgs/applications/graphics/nomacs/default.nix
  98. 2
      pkgs/applications/graphics/openscad/default.nix
  99. 2
      pkgs/applications/graphics/processing3/default.nix
  100. 2
      pkgs/applications/graphics/sane/backends/generic.nix
  101. Some files were not shown because too many files have changed in this diff Show More

4
pkgs/applications/altcoins/clightning.nix

@ -1,5 +1,5 @@
{ stdenv, fetchpatch, python3, pkgconfig, which, libtool, autoconf, automake,
autogen, git, sqlite, gmp, zlib, fetchFromGitHub }:
{ stdenv, python3, pkgconfig, which, libtool, autoconf, automake,
autogen, sqlite, gmp, zlib, fetchFromGitHub }:
with stdenv.lib;
stdenv.mkDerivation rec {

2
pkgs/applications/altcoins/default.nix

@ -88,5 +88,5 @@ rec {
parity = callPackage ./parity { };
parity-ui = callPackage ./parity-ui { };
particl-core = callPackage ./particl/particl-core.nix { boost = boost165; miniupnpc = miniupnpc_2; withGui = false; };
particl-core = callPackage ./particl/particl-core.nix { boost = boost165; miniupnpc = miniupnpc_2; };
}

2
pkgs/applications/altcoins/dero.nix

@ -1,5 +1,5 @@
{ lib, stdenv, fetchFromGitHub, cmake, pkgconfig, unbound, openssl, boost
, libunwind, lmdb, miniupnpc, readline }:
, lmdb, miniupnpc, readline }:
stdenv.mkDerivation rec {
name = "dero-${version}";

2
pkgs/applications/altcoins/dogecoin.nix

@ -1,7 +1,7 @@
{ stdenv , fetchFromGitHub
, pkgconfig, autoreconfHook
, db5, openssl, boost, zlib, miniupnpc
, glib, protobuf, utillinux, qt4, qrencode
, protobuf, utillinux, qt4, qrencode
, withGui }:
with stdenv.lib;

2
pkgs/applications/altcoins/ethsign/default.nix

@ -1,4 +1,4 @@
{ stdenv, buildGoPackage, fetchFromGitHub, fetchgit, clang }:
{ stdenv, buildGoPackage, fetchFromGitHub, fetchgit }:
buildGoPackage rec {
name = "ethsign-${version}";

2
pkgs/applications/altcoins/freicoin.nix

@ -1,4 +1,4 @@
{ fetchFromGitHub, stdenv, db, boost, gmp, mpfr, miniupnpc, qt4, qmake4Hook, unzip }:
{ fetchFromGitHub, stdenv, db, boost, gmp, mpfr, qt4, qmake4Hook }:
stdenv.mkDerivation rec {
version = "0.8.6-2";

2
pkgs/applications/altcoins/go-ethereum-classic/default.nix

@ -1,4 +1,4 @@
{ stdenv, lib, buildGoPackage, fetchgit, fetchhg, fetchbzr, fetchsvn }:
{ lib, buildGoPackage, fetchgit }:
buildGoPackage rec {
name = "go-ethereum-classic-${version}";

2
pkgs/applications/altcoins/go-ethereum.nix

@ -1,4 +1,4 @@
{ stdenv, lib, buildGoPackage, fetchFromGitHub, libobjc, IOKit }:
{ stdenv, buildGoPackage, fetchFromGitHub, libobjc, IOKit }:
buildGoPackage rec {
name = "go-ethereum-${version}";

4
pkgs/applications/altcoins/hevm.nix

@ -5,12 +5,12 @@
, lens-aeson, memory, monad-par, mtl, optparse-generic, process
, QuickCheck, quickcheck-text, readline, rosezipper, scientific
, stdenv, tasty, tasty-hunit, tasty-quickcheck, temporary, text
, text-format, time, unordered-containers, vector, vty
, text-format, unordered-containers, vector, vty
, restless-git
, fetchFromGitHub, lib, makeWrapper
, ncurses, zlib, bzip2, solc, coreutils
, zlib, bzip2, solc, coreutils
, bash
}:

2
pkgs/applications/altcoins/mist.nix

@ -1,4 +1,4 @@
{ stdenv, lib, makeWrapper, fetchurl, unzip, atomEnv, makeDesktopItem, buildFHSUserEnv }:
{ stdenv, makeWrapper, fetchurl, unzip, atomEnv, makeDesktopItem, buildFHSUserEnv }:
let
version = "0.10.0";

2
pkgs/applications/altcoins/namecoin.nix

@ -1,4 +1,4 @@
{ stdenv, lib, fetchFromGitHub, openssl, boost, libevent, autoreconfHook, db4, miniupnpc, eject, pkgconfig, qt4, protobuf, libqrencode
{ stdenv, fetchFromGitHub, openssl, boost, libevent, autoreconfHook, db4, miniupnpc, eject, pkgconfig, qt4, protobuf, libqrencode
, withGui }:
with stdenv.lib;

2
pkgs/applications/altcoins/nano-wallet/default.nix

@ -1,4 +1,4 @@
{lib, pkgs, stdenv, fetchFromGitHub, cmake, pkgconfig, boost, libGL, qtbase}:
{lib, stdenv, fetchFromGitHub, cmake, pkgconfig, boost, libGL, qtbase}:
stdenv.mkDerivation rec {

2
pkgs/applications/altcoins/parity-ui/default.nix

@ -1,4 +1,4 @@
{ stdenv, pkgs, fetchurl, lib, makeWrapper, nodePackages }:
{ stdenv, pkgs, fetchurl, makeWrapper, nodePackages }:
let

2
pkgs/applications/altcoins/parity-ui/env.nix

@ -1,5 +1,5 @@
{ stdenv, lib, zlib, glib, alsaLib, dbus, gtk2, atk, pango, freetype, fontconfig
, libgnome-keyring3, gdk_pixbuf, gvfs, cairo, cups, expat, libgpgerror, nspr
, libgnome-keyring3, gdk_pixbuf, cairo, cups, expat, libgpgerror, nspr
, nss, xorg, libcap, systemd, libnotify, libsecret, gnome3 }:
let

3
pkgs/applications/altcoins/particl/particl-core.nix

@ -4,14 +4,11 @@
, db48
, fetchurl
, libevent
, libtool
, miniupnpc
, openssl
, pkgconfig
, utillinux
, zeromq
, zlib
, withGui
, unixtools
}:

2
pkgs/applications/altcoins/stellar-core.nix

@ -1,4 +1,4 @@
{ stdenv, lib, fetchgit, autoconf, libtool, automake, pkgconfig, git
{ stdenv, fetchgit, autoconf, libtool, automake, pkgconfig, git
, bison, flex, postgresql }:
let

4
pkgs/applications/audio/abcde/default.nix

@ -1,5 +1,5 @@
{ stdenv, fetchurl, libcdio-paranoia, cddiscid, wget, bash, which, vorbis-tools, id3v2, eyeD3
, lame, flac, eject, mkcue, glyr
{ stdenv, fetchurl, libcdio-paranoia, cddiscid, wget, which, vorbis-tools, id3v2, eyeD3
, lame, flac, glyr
, perl, DigestSHA, MusicBrainz, MusicBrainzDiscID
, makeWrapper }:

2
pkgs/applications/audio/airwave/default.nix

@ -1,5 +1,5 @@
{ stdenv, multiStdenv, cmake, fetchFromGitHub, file, libX11, makeWrapper
, overrideCC, qt5, requireFile, unzip, wine
, qt5, requireFile, unzip, wine
}:
let

4
pkgs/applications/audio/audacity/default.nix

@ -1,5 +1,5 @@
{ stdenv, fetchurl, wxGTK30, pkgconfig, file, gettext, gtk2, glib, zlib, perl, intltool,
libogg, libvorbis, libmad, libjack2, lv2, lilv, serd, sord, sratom, suil, alsaLib, libsndfile, soxr, flac, lame,
{ stdenv, fetchurl, wxGTK30, pkgconfig, file, gettext, gtk2,
libvorbis, libmad, libjack2, lv2, lilv, serd, sord, sratom, suil, alsaLib, libsndfile, soxr, flac, lame,
expat, libid3tag, ffmpeg, soundtouch, /*, portaudio - given up fighting their portaudio.patch */
autoconf, automake, libtool
}:

2
pkgs/applications/audio/banshee/default.nix

@ -1,4 +1,4 @@
{ pkgs, stdenv, lib, fetchurl, intltool, pkgconfig, gstreamer, gst-plugins-base
{ stdenv, lib, fetchurl, intltool, pkgconfig, gstreamer, gst-plugins-base
, gst-plugins-good, gst-plugins-bad, gst-plugins-ugly, gst-ffmpeg, glib
, mono, mono-addins, dbus-sharp-1_0, dbus-sharp-glib-1_0, notify-sharp, gtk-sharp-2_0
, boo, gdata-sharp, taglib-sharp, sqlite, gnome-sharp, gconf, gtk-sharp-beans, gio-sharp

2
pkgs/applications/audio/clementine/default.nix

@ -1,7 +1,7 @@
{ stdenv, fetchurl, fetchpatch, boost, cmake, chromaprint, gettext, gst_all_1, liblastfm
, qt4, taglib, fftw, glew, qjson, sqlite, libgpod, libplist, usbmuxd, libmtp
, libpulseaudio, gvfs, libcdio, libechonest, libspotify, pcre, projectm, protobuf
, qca2, pkgconfig, sparsehash, config, makeWrapper, runCommand, gst_plugins }:
, qca2, pkgconfig, sparsehash, config, makeWrapper, gst_plugins }:
let
withIpod = config.clementine.ipod or false;

2
pkgs/applications/audio/deadbeef/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, intltool, pkgconfig, fetchpatch, jansson
{ stdenv, fetchurl, intltool, pkgconfig, jansson
# deadbeef can use either gtk2 or gtk3
, gtk2Support ? false, gtk2 ? null
, gtk3Support ? true, gtk3 ? null, gsettings-desktop-schemas ? null, wrapGAppsHook ? null

2
pkgs/applications/audio/deadbeef/wrapper.nix

@ -1,4 +1,4 @@
{ stdenv, symlinkJoin, deadbeef, makeWrapper, plugins }:
{ symlinkJoin, deadbeef, makeWrapper, plugins }:
symlinkJoin {
name = "deadbeef-with-plugins-${deadbeef.version}";

2
pkgs/applications/audio/distrho/default.nix

@ -1,5 +1,5 @@
{ stdenv, fetchFromGitHub, alsaLib, fftwSinglePrec, freetype, libjack2
, libxslt, lv2, pkgconfig, premake3, xorg, ladspa-sdk }:
, pkgconfig, premake3, xorg, ladspa-sdk }:
stdenv.mkDerivation rec {
name = "distrho-ports-unstable-2018-01-01";

1
pkgs/applications/audio/faust/faust2.nix

@ -3,7 +3,6 @@
, fetchFromGitHub
, makeWrapper
, pkgconfig
, clang
, llvm
, emscripten
, openssl

2
pkgs/applications/audio/fmit/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchFromGitHub, fftw, freeglut, libGLU, qtbase, qtmultimedia, qmake
{ stdenv, fetchFromGitHub, fftw, qtbase, qtmultimedia, qmake
, alsaSupport ? true, alsaLib ? null
, jackSupport ? false, libjack2 ? null
, portaudioSupport ? false, portaudio ? null }:

1
pkgs/applications/audio/gradio/default.nix

@ -1,5 +1,4 @@
{ stdenv, fetchFromGitHub, pkgconfig
, gcc
, python3
, gsettings-desktop-schemas
, desktop-file-utils

4
pkgs/applications/audio/gtkpod/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, pkgconfig, wrapGAppsHook, intltool, libgpod, curl, flac,
gnome3, gtk3, glib, gettext, perl, perlXMLParser, flex, libid3tag,
libvorbis, hicolor-icon-theme, gdk_pixbuf }:
gnome3, gtk3, gettext, perl, perlXMLParser, flex, libid3tag,
libvorbis, gdk_pixbuf }:
stdenv.mkDerivation rec {
version = "2.1.5";

2
pkgs/applications/audio/jaaa/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, alsaLib, libclthreads, libclxclient, libX11, libXft, libXrender, fftwFloat, freetype, fontconfig, libjack2, xorg, zita-alsa-pcmi }:
{ stdenv, fetchurl, alsaLib, libclthreads, libclxclient, libX11, libXft, libXrender, fftwFloat, libjack2, zita-alsa-pcmi }:
stdenv.mkDerivation rec {
name = "jaaa-${version}";

2
pkgs/applications/audio/lastfmsubmitd/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, pythonPackages }:
{ fetchurl, pythonPackages }:
pythonPackages.buildPythonApplication rec {
pname = "lastfmsubmitd";

2
pkgs/applications/audio/magnetophonDSP/VoiceOfFaust/default.nix

@ -1,4 +1,4 @@
{ stdenv, pkgs, callPackage, fetchFromGitHub, faust2jack, faust2lv2, helmholtz, mrpeach, puredata-with-plugins }:
{ stdenv, fetchFromGitHub, faust2jack, faust2lv2, helmholtz, mrpeach, puredata-with-plugins }:
stdenv.mkDerivation rec {
name = "VoiceOfFaust-${version}";
version = "1.1.4";

2
pkgs/applications/audio/mikmod/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, libmikmod, ncurses, alsaLib }:
{ stdenv, fetchurl, libmikmod, ncurses }:
stdenv.mkDerivation rec {
name = "mikmod-3.2.8";

2
pkgs/applications/audio/mopidy/mopify.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, pythonPackages, mopidy }:
{ stdenv, pythonPackages, mopidy }:
pythonPackages.buildPythonApplication rec {
pname = "Mopidy-Mopify";

2
pkgs/applications/audio/pianobar/default.nix

@ -1,4 +1,4 @@
{ fetchurl, stdenv, pkgconfig, libao, readline, json_c, libgcrypt, libav, curl }:
{ fetchurl, stdenv, pkgconfig, libao, json_c, libgcrypt, libav, curl }:
stdenv.mkDerivation rec {
name = "pianobar-2016.06.02";

2
pkgs/applications/audio/picard/default.nix

@ -1,4 +1,4 @@
{ stdenv, python2Packages, fetchurl, gettext, chromaprint }:
{ stdenv, python2Packages, fetchurl, gettext }:
let
pythonPackages = python2Packages;

2
pkgs/applications/audio/puddletag/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchFromGitHub, python2Packages, makeWrapper, chromaprint }:
{ stdenv, fetchFromGitHub, python2Packages, chromaprint }:
python2Packages.buildPythonApplication rec {
pname = "puddletag";

2
pkgs/applications/audio/puredata/wrapper.nix

@ -1,4 +1,4 @@
{ stdenv, symlinkJoin, puredata, makeWrapper, plugins }:
{ symlinkJoin, puredata, makeWrapper, plugins }:
let
puredataFlags = map (x: "-path ${x}/") plugins;

2
pkgs/applications/audio/rkrlv2/default.nix

@ -1,4 +1,4 @@
{ stdenv, pkgs, fetchFromGitHub,
{ stdenv, fetchFromGitHub,
automake, pkgconfig, lv2, fftw, cmake, xorg, libjack2, libsamplerate, libsndfile
}:

2
pkgs/applications/audio/sonata/default.nix

@ -1,4 +1,4 @@
{ lib, stdenv, fetchFromGitHub, pkgconfig, intltool, wrapGAppsHook
{ stdenv, fetchFromGitHub, pkgconfig, intltool, wrapGAppsHook
, python3Packages, gnome3, gtk3, gobjectIntrospection}:
let

2
pkgs/applications/audio/ympd/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchFromGitHub, cmake, llvmPackages, pkgconfig, mpd_clientlib, openssl }:
{ stdenv, fetchFromGitHub, cmake, pkgconfig, mpd_clientlib, openssl }:
stdenv.mkDerivation rec {
name = "ympd-${version}";

2
pkgs/applications/backup/crashplan/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, makeWrapper, jre, cpio, gawk, gnugrep, gnused, procps, swt, gtk2, glib, libXtst }:
{ stdenv, fetchurl, makeWrapper, jre, cpio, gawk, gnugrep, gnused, procps, gtk2, glib, libXtst }:
stdenv.mkDerivation rec {
version = "4.8.3";

2
pkgs/applications/display-managers/lightdm/default.nix

@ -1,5 +1,5 @@
{ stdenv, fetchurl, pam, pkgconfig, libxcb, glib, libXdmcp, itstool, libxml2
, intltool, xlibsWrapper, libxklavier, libgcrypt, audit, coreutils
, intltool, libxklavier, libgcrypt, audit, coreutils
, qt4 ? null
, withQt5 ? false, qtbase
}:

4
pkgs/applications/display-managers/sddm/default.nix

@ -1,5 +1,5 @@
{ mkDerivation, lib, fetchFromGitHub, fetchpatch
, cmake, extra-cmake-modules, pkgconfig, libxcb, libpthreadstubs, lndir
{ mkDerivation, lib, fetchFromGitHub
, cmake, extra-cmake-modules, pkgconfig, libxcb, libpthreadstubs
, libXdmcp, libXau, qtbase, qtdeclarative, qttools, pam, systemd
}:

2
pkgs/applications/editors/android-studio/default.nix

@ -1,4 +1,4 @@
{ stdenv, callPackage, fetchurl, makeFontsConf, gnome2 }:
{ stdenv, callPackage, makeFontsConf, gnome2 }:
let
mkStudio = opts: callPackage (import ./common.nix opts) {

2
pkgs/applications/editors/atom/default.nix

@ -1,4 +1,4 @@
{ stdenv, pkgs, fetchurl, lib, makeWrapper, gvfs, atomEnv}:
{ stdenv, pkgs, fetchurl, makeWrapper, gvfs, atomEnv}:
let
common = pname: {version, sha256}: stdenv.mkDerivation rec {

2
pkgs/applications/editors/atom/env.nix

@ -1,5 +1,5 @@
{ stdenv, lib, zlib, glib, alsaLib, dbus, gtk3, atk, pango, freetype, fontconfig
, libgnome-keyring3, gdk_pixbuf, gvfs, cairo, cups, expat, libgpgerror, nspr
, libgnome-keyring3, gdk_pixbuf, cairo, cups, expat, libgpgerror, nspr
, gconf, nss, xorg, libcap, systemd, libnotify, libsecret
}:

4
pkgs/applications/editors/brackets/default.nix

@ -1,5 +1,5 @@
{ stdenv, fetchurl, buildEnv, gtk2, glib, gdk_pixbuf, alsaLib, nss, nspr, gconf
, cups, libgcrypt_1_5, systemd, makeWrapper, dbus }:
{ stdenv, fetchurl, gtk2, glib, gdk_pixbuf, alsaLib, nss, nspr, gconf
, cups, libgcrypt_1_5, systemd, dbus }:
with stdenv.lib;
let

2
pkgs/applications/editors/dit/default.nix

@ -1,4 +1,4 @@
{ lib, fetchurl, stdenv, coreutils, ncurses, lua }:
{ fetchurl, stdenv, coreutils, ncurses, lua }:
stdenv.mkDerivation rec {
name = "dit-${version}";

6
pkgs/applications/editors/eclipse/default.nix

@ -1,8 +1,8 @@
{ stdenv, lib, fetchurl, makeDesktopItem, makeWrapper
, freetype, fontconfig, libX11, libXext, libXrender, zlib
{ stdenv, fetchurl, makeDesktopItem, makeWrapper
, freetype, fontconfig, libX11, libXrender, zlib
, glib, gtk3, libXtst, jdk, gsettings-desktop-schemas
, webkitgtk ? null # for internal web browser
, buildEnv, writeText, runCommand
, buildEnv, runCommand
, callPackage
}:

2
pkgs/applications/editors/emacs-modes/emacs-clang-complete-async/default.nix

@ -1,4 +1,4 @@
{ clangStdenv, fetchgit, llvmPackages, clang }:
{ clangStdenv, fetchgit, llvmPackages }:
clangStdenv.mkDerivation {
name = "emacs-clang-complete-async-20130218";

2
pkgs/applications/editors/emacs-modes/filesets-plus/default.nix

@ -1,4 +1,4 @@
{ fetchurl, lib, stdenv, melpaBuild }:
{ fetchurl, melpaBuild }:
melpaBuild {
pname = "filesets-plus";

2
pkgs/applications/editors/emacs-modes/font-lock-plus/default.nix

@ -1,4 +1,4 @@
{ fetchurl, lib, stdenv, melpaBuild }:
{ fetchurl, lib, melpaBuild }:
melpaBuild {
pname = "font-lock-plus";

2
pkgs/applications/editors/emacs-modes/header2/default.nix

@ -1,4 +1,4 @@
{ fetchurl, lib, stdenv, melpaBuild }:
{ fetchurl, lib, melpaBuild }:
melpaBuild {
pname = "header2";

2
pkgs/applications/editors/emacs-modes/hexrgb/default.nix

@ -1,4 +1,4 @@
{ fetchurl, lib, stdenv, melpaBuild }:
{ fetchurl, lib, melpaBuild }:
melpaBuild {
pname = "hexrgb";

2
pkgs/applications/editors/emacs-modes/lib-requires/default.nix

@ -1,4 +1,4 @@
{ fetchurl, lib, stdenv, melpaBuild }:
{ fetchurl, lib, melpaBuild }:
melpaBuild {
pname = "lib-requires";

2
pkgs/applications/editors/emacs-modes/melpa-stable-packages.nix

@ -13,7 +13,7 @@ To update the list of packages from MELPA,
*/
{ lib, external }:
{ external }:
self:

2
pkgs/applications/editors/emacs-modes/ocaml/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, emacs, ocaml }:
{ stdenv, emacs, ocaml }:
# this package installs the emacs-mode which
# resides in the ocaml compiler sources.

2
pkgs/applications/editors/emacs-modes/org-packages.nix

@ -11,7 +11,7 @@ To update the list of packages from ELPA,
*/
{ fetchurl, lib, stdenv, texinfo }:
{ }:
self:

2
pkgs/applications/editors/emacs-modes/org/default.nix

@ -1,4 +1,4 @@
{ fetchurl, stdenv, emacs, texinfo, which, texlive }:
{ fetchurl, stdenv, emacs, texinfo, texlive }:
stdenv.mkDerivation rec {
name = "org-8.3.3";

2
pkgs/applications/editors/emacs-modes/thingatpt-plus/default.nix

@ -1,4 +1,4 @@
{ fetchurl, lib, stdenv, melpaBuild }:
{ fetchurl, lib, melpaBuild }:
melpaBuild {
pname = "thingatpt-plus";

2
pkgs/applications/editors/emacs/25.nix

@ -1,7 +1,7 @@
{ stdenv, lib, fetchurl, ncurses, xlibsWrapper, libXaw, libXpm, Xaw3d
, pkgconfig, gettext, libXft, dbus, libpng, libjpeg, libungif
, libtiff, librsvg, gconf, libxml2, imagemagick, gnutls, libselinux
, alsaLib, cairo, acl, gpm, AppKit, CoreWLAN, Kerberos, GSS, ImageIO
, alsaLib, cairo, acl, gpm, AppKit, GSS, ImageIO
, withX ? !stdenv.isDarwin
, withGTK2 ? false, gtk2 ? null
, withGTK3 ? true, gtk3 ? null, gsettings-desktop-schemas ? null

2
pkgs/applications/editors/emacs/default.nix

@ -1,7 +1,7 @@
{ stdenv, lib, fetchurl, ncurses, xlibsWrapper, libXaw, libXpm, Xaw3d
, pkgconfig, gettext, libXft, dbus, libpng, libjpeg, libungif
, libtiff, librsvg, gconf, libxml2, imagemagick, gnutls, libselinux
, alsaLib, cairo, acl, gpm, AppKit, CoreWLAN, Kerberos, GSS, ImageIO
, alsaLib, cairo, acl, gpm, AppKit, GSS, ImageIO
, withX ? !stdenv.isDarwin
, withGTK2 ? false, gtk2 ? null
, withGTK3 ? true, gtk3 ? null, gsettings-desktop-schemas ? null

4
pkgs/applications/editors/jetbrains/common.nix

@ -1,5 +1,5 @@
{ stdenv, fetchurl, makeDesktopItem, makeWrapper, patchelf, p7zip
, coreutils, gnugrep, which, git, python, unzip, libsecret
{ stdenv, makeDesktopItem, makeWrapper, patchelf, p7zip
, coreutils, gnugrep, which, git, unzip, libsecret
}:
{ name, product, version, src, wmClass, jdk, meta } @ attrs:

24
pkgs/applications/editors/jetbrains/default.nix

@ -1,6 +1,6 @@
{ lib, stdenv, callPackage, fetchurl, makeDesktopItem, makeWrapper, patchelf
, coreutils, gnugrep, which, git, python, unzip, p7zip
, androidsdk, jdk, cmake, libxml2, zlib, python3, ncurses
{ lib, stdenv, callPackage, fetchurl
, python
, jdk, cmake, libxml2, zlib, python3, ncurses
}:
with stdenv.lib;
@ -10,7 +10,7 @@ let
# Sorted alphabetically
buildClion = { name, version, src, license, description, wmClass, update-channel }:
buildClion = { name, version, src, license, description, wmClass, ... }:
lib.overrideDerivation (mkJetBrainsProduct rec {
inherit name version src wmClass jdk;
product = "CLion";
@ -66,7 +66,7 @@ let
'';
});
buildDataGrip = { name, version, src, license, description, wmClass, update-channel }:
buildDataGrip = { name, version, src, license, description, wmClass, ... }:
(mkJetBrainsProduct {
inherit name version src wmClass jdk;
product = "DataGrip";
@ -83,7 +83,7 @@ let
};
});
buildGoland = { name, version, src, license, description, wmClass, update-channel }:
buildGoland = { name, version, src, license, description, wmClass, ... }:
lib.overrideDerivation (mkJetBrainsProduct {
inherit name version src wmClass jdk;
product = "Goland";
@ -108,7 +108,7 @@ let
'';
});
buildIdea = { name, version, src, license, description, wmClass, update-channel }:
buildIdea = { name, version, src, license, description, wmClass, ... }:
(mkJetBrainsProduct rec {
inherit name version src wmClass jdk;
product = "IDEA";
@ -125,7 +125,7 @@ let
};
});
buildPhpStorm = { name, version, src, license, description, wmClass, update-channel }:
buildPhpStorm = { name, version, src, license, description, wmClass, ... }:
(mkJetBrainsProduct {
inherit name version src wmClass jdk;
product = "PhpStorm";
@ -142,7 +142,7 @@ let
};
});
buildPycharm = { name, version, src, license, description, wmClass, update-channel }:
buildPycharm = { name, version, src, license, description, wmClass, ... }:
(mkJetBrainsProduct rec {
inherit name version src wmClass jdk;
product = "PyCharm";
@ -169,7 +169,7 @@ let
propagatedUserEnvPkgs = [ python ];
};
buildRider = { name, version, src, license, description, wmClass, update-channel }:
buildRider = { name, version, src, license, description, wmClass, ... }:
lib.overrideDerivation (mkJetBrainsProduct rec {
inherit name version src wmClass jdk;
product = "Rider";
@ -195,7 +195,7 @@ let
'';
});
buildRubyMine = { name, version, src, license, description, wmClass, update-channel }:
buildRubyMine = { name, version, src, license, description, wmClass, ... }:
(mkJetBrainsProduct rec {
inherit name version src wmClass jdk;
product = "RubyMine";
@ -208,7 +208,7 @@ let
};
});
buildWebStorm = { name, version, src, license, description, wmClass, update-channel }:
buildWebStorm = { name, version, src, license, description, wmClass, ... }:
lib.overrideDerivation (mkJetBrainsProduct {
inherit name version src wmClass jdk;
product = "WebStorm";

2
pkgs/applications/editors/jucipp/default.nix

@ -1,4 +1,4 @@
{ config, stdenv, fetchgit, makeWrapper, gnome3, at-spi2-core, libcxx,
{ stdenv, fetchgit, gnome3, at-spi2-core,
boost, epoxy, cmake, aspell, llvmPackages, libgit2, pkgconfig, pcre,
libXdmcp, libxkbcommon, libpthreadstubs, wrapGAppsHook, aspellDicts,
coreutils, glibc, dbus, openssl, libxml2, gnumake, ctags }:

2
pkgs/applications/editors/kakoune/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchFromGitHub, ncurses, boost, asciidoc, docbook_xsl, libxslt, pkgconfig }:
{ stdenv, fetchFromGitHub, ncurses, asciidoc, docbook_xsl, libxslt, pkgconfig }:
with stdenv.lib;

2
pkgs/applications/editors/kodestudio/default.nix

@ -1,4 +1,4 @@
{ stdenv, lib, callPackage, fetchurl, makeDesktopItem, makeWrapper
{ stdenv, lib, fetchurl, makeDesktopItem, makeWrapper
, # Patchelf dependencies:
alsaLib, atomEnv, boehmgc, flac, libogg, libvorbis, libXScrnSaver, libGLU_combined
, openssl, xorg, zlib

2
pkgs/applications/editors/monodevelop/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, fetchgit, fetchNuGet
{ stdenv, fetchurl
, autoconf, automake, pkgconfig, shared-mime-info, intltool
, glib, mono, gtk-sharp-2_0, gnome2, gnome-sharp, unzip
, dotnetPackages

2
pkgs/applications/editors/nano/default.nix

@ -1,4 +1,4 @@
{ stdenv, hostPlatform, fetchurl, fetchFromGitHub
{ stdenv, fetchurl, fetchFromGitHub
, ncurses
, texinfo
, gettext ? null

4
pkgs/applications/editors/neovim/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchFromGitHub, cmake, gettext, libmsgpack, libtermkey, libiconv
, libtool, libuv, luaPackages, ncurses, perl, pkgconfig
, unibilium, vimUtils, xsel, gperf, callPackage
, libuv, luaPackages, ncurses, pkgconfig
, unibilium, xsel, gperf
, libvterm-neovim
, withJemalloc ? true, jemalloc
}:

5
pkgs/applications/editors/neovim/wrapper.nix

@ -1,4 +1,4 @@
{ stdenv, lib, makeDesktopItem, makeWrapper
{ stdenv, lib, makeWrapper
, vimUtils
, bundlerEnv, ruby
, pythonPackages
@ -10,8 +10,7 @@ neovim:
let
wrapper = {
name ? "neovim"
, withPython ? true, extraPythonPackages ? []
withPython ? true, extraPythonPackages ? []
, withPython3 ? true, extraPython3Packages ? []
, withRuby ? true
, withPyGUI ? false

2
pkgs/applications/editors/nvpy/default.nix

@ -1,4 +1,4 @@
{ pkgs, fetchurl, tk, python2Packages }:
{ pkgs, fetchurl, python2Packages }:
let
pythonPackages = python2Packages;

2
pkgs/applications/editors/texmacs/darwin.nix

@ -1,4 +1,4 @@
{ stdenv, callPackage, fetchurl, makeWrapper,
{ stdenv, callPackage, fetchurl,
guile_1_8, qt4, zlib, freetype, CoreFoundation, Cocoa, gettext, libiconv, ghostscript,
tex ? null,
aspell ? null,

2
pkgs/applications/editors/tiled/default.nix

@ -1,5 +1,5 @@
{ stdenv, fetchFromGitHub, pkgconfig, qmake
, python, qtbase, qttools, zlib }:
, python, qtbase, qttools }:
stdenv.mkDerivation rec {
name = "tiled-${version}";

2
pkgs/applications/editors/typora/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, dpkg, lib, glib, dbus, makeWrapper, gnome3, gtk3, atk, cairo, pango
{ stdenv, fetchurl, dpkg, glib, dbus, makeWrapper, gnome3, gtk3, atk, cairo, pango
, gdk_pixbuf, freetype, fontconfig, nspr, nss, xorg, alsaLib, cups, expat, udev, wrapGAppsHook }:
stdenv.mkDerivation rec {

2
pkgs/applications/editors/vim/macvim.nix

@ -1,5 +1,5 @@
{ stdenv, fetchFromGitHub, ncurses, gettext
, pkgconfig, cscope, python, ruby, tcl, perl, luajit
, pkgconfig, python, ruby, tcl, perl, luajit
, darwin
}:

2
pkgs/applications/editors/vscode/default.nix

@ -1,4 +1,4 @@
{ stdenv, lib, callPackage, fetchurl, unzip, atomEnv, makeDesktopItem,
{ stdenv, lib, fetchurl, unzip, atomEnv, makeDesktopItem,
gtk2, makeWrapper, libXScrnSaver, libxkbfile, libsecret }:
let

2
pkgs/applications/editors/vscode/with-extensions.nix

@ -1,4 +1,4 @@
{ stdenv, lib, fetchurl, runCommand, buildEnv, vscode, which, writeScript
{ stdenv, lib, runCommand, buildEnv, vscode, which, writeScript
, vscodeExtensions ? [] }:
/*

2
pkgs/applications/editors/wxhexeditor/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchFromGitHub, fetchpatch, wxGTK, autoconf, automake, libtool, python, gettext, bash }:
{ stdenv, fetchFromGitHub, fetchpatch, wxGTK, autoconf, automake, libtool, python, gettext }:
stdenv.mkDerivation rec {
name = "wxHexEditor-${version}";

2
pkgs/applications/gis/qgis/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, fetchpatch, gdal, cmake, qt4, flex, bison, proj, geos, xlibsWrapper, sqlite, gsl
{ stdenv, fetchurl, gdal, cmake, qt4, flex, bison, proj, geos, xlibsWrapper, sqlite, gsl
, qwt, fcgi, python2Packages, libspatialindex, libspatialite, qscintilla, postgresql, makeWrapper
, qjson, qca2, txt2tags, openssl, darwin, pkgconfig
, withGrass ? true, grass, IOKit, ApplicationServices

4
pkgs/applications/graphics/ImageMagick/7.0.nix

@ -1,8 +1,8 @@
{ lib, stdenv, fetchFromGitHub, fetchpatch, pkgconfig, libtool
{ lib, stdenv, fetchFromGitHub, pkgconfig, libtool
, bzip2, zlib, libX11, libXext, libXt, fontconfig, freetype, ghostscript, libjpeg
, lcms2, openexr, libpng, librsvg, libtiff, libxml2, openjpeg, libwebp, libheif
, ApplicationServices
, buildPlatform, hostPlatform
, hostPlatform
}:
let

2
pkgs/applications/graphics/ImageMagick/default.nix

@ -2,7 +2,7 @@
, bzip2, zlib, libX11, libXext, libXt, fontconfig, freetype, ghostscript, libjpeg
, lcms2, openexr, libpng, librsvg, libtiff, libxml2, openjpeg, libwebp, fftw, libheif, libde265
, ApplicationServices
, buildPlatform, hostPlatform
, hostPlatform
}:
let

2
pkgs/applications/graphics/ahoviewer/default.nix

@ -1,4 +1,4 @@
{ stdenv, pkgs, fetchurl, fetchFromGitHub, pkgconfig, libconfig,
{ stdenv, fetchFromGitHub, pkgconfig, libconfig,
gtkmm2, glibmm, libxml2, libsecret, curl, libzip,
librsvg, gst_all_1, autoreconfHook, makeWrapper,
useUnrar ? false, unrar

2
pkgs/applications/graphics/avocode/default.nix

@ -1,4 +1,4 @@
{ stdenv, lib, makeDesktopItem, fetchurl, unzip
{ stdenv, makeDesktopItem, fetchurl, unzip
, gdk_pixbuf, glib, gtk2, atk, pango, cairo, freetype, fontconfig, dbus, nss, nspr, alsaLib, cups, expat, udev, gnome2
, xorg, mozjpeg
}:

2
pkgs/applications/graphics/awesomebump/default.nix

@ -1,4 +1,4 @@
{ lib, stdenv, fetchgit, qtbase, qmake, makeWrapper, qtscript, gcc, flex, bison, qtdeclarative, gnutar }:
{ lib, stdenv, fetchgit, qtbase, qmake, makeWrapper, qtscript, flex, bison, qtdeclarative }:
let

3
pkgs/applications/graphics/digikam/default.nix

@ -1,4 +1,4 @@
{ mkDerivation, lib, fetchFromGitHub, cmake, doxygen, extra-cmake-modules, wrapGAppsHook, fetchpatch
{ mkDerivation, lib, fetchFromGitHub, cmake, doxygen, extra-cmake-modules, wrapGAppsHook
# For `digitaglinktree`
, perl, sqlite
@ -35,7 +35,6 @@
, libusb1
, marble
, libGLU_combined
, mysql
, opencv3
, pcre
, threadweaver

2
pkgs/applications/graphics/dosage/default.nix

@ -1,4 +1,4 @@
{ stdenv, pythonPackages, fetchFromGitHub }:
{ pythonPackages, fetchFromGitHub }:
pythonPackages.buildPythonApplication rec {
pname = "dosage";

2
pkgs/applications/graphics/epeg/default.nix

@ -1,4 +1,4 @@
{ lib, stdenv, fetchFromGitHub, pkgconfig, libtool, autoconf, automake
{ stdenv, fetchFromGitHub, pkgconfig, libtool, autoconf, automake
, libjpeg, libexif
}:

2
pkgs/applications/graphics/fstl/default.nix

@ -1,4 +1,4 @@
{stdenv, fetchFromGitHub, qtbase, mesa_glu, qmake}:
{stdenv, fetchFromGitHub, qtbase, mesa_glu}:
stdenv.mkDerivation rec {
name = "fstl-${version}";
version = "0.9.3";

2
pkgs/applications/graphics/glabels/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, barcode, gnome3, autoreconfHook
, gtk3, gtk-doc, libxml2, librsvg , libtool, libe-book
, intltool, itstool, makeWrapper, pkgconfig, which
, intltool, itstool, makeWrapper, pkgconfig
}:
stdenv.mkDerivation rec {

2
pkgs/applications/graphics/goxel/default.nix

@ -1,4 +1,4 @@
{ stdenv, lib, fetchFromGitHub, scons, pkgconfig, wrapGAppsHook
{ stdenv, fetchFromGitHub, scons, pkgconfig, wrapGAppsHook
, glfw3, gtk3, libpng12 }:
stdenv.mkDerivation rec {

2
pkgs/applications/graphics/graphicsmagick/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, fetchpatch, bzip2, freetype, graphviz, ghostscript
{ stdenv, fetchurl, bzip2, freetype, graphviz, ghostscript
, libjpeg, libpng, libtiff, libxml2, zlib, libtool, xz, libX11
, libwebp, quantumdepth ? 8, fixDarwinDylibNames }:

2
pkgs/applications/graphics/inkscape/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, fetchpatch, pkgconfig, perl, perlXMLParser, libXft
{ stdenv, fetchurl, pkgconfig, perl, perlXMLParser, libXft
, libpng, zlib, popt, boehmgc, libxml2, libxslt, glib, gtkmm2
, glibmm, libsigcxx, lcms, boost, gettext, makeWrapper
, gsl, python2, poppler, imagemagick, libwpg, librevenge

2
pkgs/applications/graphics/k3d/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchFromGitHub, fetchpatch, unzip, ftgl, glew, asciidoc
{ stdenv, fetchFromGitHub, fetchpatch, ftgl, glew, asciidoc
, cmake, ninja, libGLU_combined, zlib, python, expat, libxml2, libsigcxx, libuuid, freetype
, libpng, boost, doxygen, cairomm, pkgconfig, imagemagick, libjpeg, libtiff
, gettext, intltool, perl, gtkmm2, glibmm, gtkglext, pangox_compat, libXmu }:

2
pkgs/applications/graphics/kgraphviewer/default.nix

@ -1,5 +1,5 @@
{ stdenv, mkDerivation, fetchurl, cmake, extra-cmake-modules, pkgconfig, wrapGAppsHook
, kconfig, kcrash, kinit, kdoctools, kiconthemes, kio, kparts, kwidgetsaddons
, kconfig, kinit, kdoctools, kio, kparts, kwidgetsaddons
, qtbase, qtsvg
, boost, graphviz
}:

2
pkgs/applications/graphics/krita/default.nix

@ -1,4 +1,4 @@
{ mkDerivation, lib, fetchurl, fetchpatch, cmake, extra-cmake-modules
{ mkDerivation, lib, fetchurl, cmake, extra-cmake-modules
, karchive, kconfig, kwidgetsaddons, kcompletion, kcoreaddons
, kguiaddons, ki18n, kitemmodels, kitemviews, kwindowsystem
, kio, kcrash

1
pkgs/applications/graphics/nomacs/default.nix

@ -1,7 +1,6 @@
{ stdenv
, fetchFromGitHub
, cmake
, makeWrapper
, pkgconfig
, wrapGAppsHook
, gsettings-desktop-schemas

2
pkgs/applications/graphics/openscad/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, fetchFromGitHub, qt5, libsForQt5
{ stdenv, fetchFromGitHub, qt5, libsForQt5
, bison, flex, eigen, boost, libGLU_combined, glew, opencsg, cgal
, mpfr, gmp, glib, pkgconfig, harfbuzz, gettext
}:

2
pkgs/applications/graphics/processing3/default.nix

@ -1,4 +1,4 @@
{ stdenv, callPackage, fetchFromGitHub, fetchurl, xmlstarlet, makeWrapper, ant, jdk, rsync, javaPackages, libXxf86vm, gsettings-desktop-schemas }:
{ stdenv, fetchFromGitHub, fetchurl, xmlstarlet, makeWrapper, ant, jdk, rsync, javaPackages, libXxf86vm, gsettings-desktop-schemas }:
stdenv.mkDerivation rec {
version = "3.3.7";

2
pkgs/applications/graphics/sane/backends/generic.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl
{ stdenv
, avahi, libjpeg, libusb1, libv4l, net_snmp, libpng
, gettext, pkgconfig

Some files were not shown because too many files have changed in this diff Show More

Loading…
Cancel
Save