Browse Source

buildPythonApplication: use new function for Python applications

nixos-19.03
Frederik Rietdijk 6 years ago
parent
commit
4d06bf70f4
  1. 4
      pkgs/applications/audio/gpodder/default.nix
  2. 2
      pkgs/applications/audio/gtklick/default.nix
  3. 2
      pkgs/applications/audio/lastfmsubmitd/default.nix
  4. 2
      pkgs/applications/audio/lastwatch/default.nix
  5. 2
      pkgs/applications/audio/mimms/default.nix
  6. 2
      pkgs/applications/audio/mopidy-gmusic/default.nix
  7. 2
      pkgs/applications/audio/mopidy-moped/default.nix
  8. 2
      pkgs/applications/audio/mopidy-mopify/default.nix
  9. 2
      pkgs/applications/audio/mopidy-musicbox-webclient/default.nix
  10. 2
      pkgs/applications/audio/mopidy-soundcloud/default.nix
  11. 2
      pkgs/applications/audio/mopidy-spotify-tunigo/default.nix
  12. 2
      pkgs/applications/audio/mopidy-spotify/default.nix
  13. 2
      pkgs/applications/audio/mopidy-youtube/default.nix
  14. 2
      pkgs/applications/audio/mopidy/default.nix
  15. 4
      pkgs/applications/audio/picard/default.nix
  16. 2
      pkgs/applications/audio/pithos/default.nix
  17. 4
      pkgs/applications/audio/quodlibet/default.nix
  18. 4
      pkgs/applications/audio/sonata/default.nix
  19. 2
      pkgs/applications/editors/leo-editor/default.nix
  20. 4
      pkgs/applications/editors/nvpy/default.nix
  21. 4
      pkgs/applications/graphics/jbrout/default.nix
  22. 4
      pkgs/applications/graphics/mcomix/default.nix
  23. 4
      pkgs/applications/graphics/mirage/default.nix
  24. 2
      pkgs/applications/misc/bleachbit/default.nix
  25. 4
      pkgs/applications/misc/electrum-dash/default.nix
  26. 4
      pkgs/applications/misc/electrum/default.nix
  27. 4
      pkgs/applications/misc/gramps/default.nix
  28. 4
      pkgs/applications/misc/hamster-time-tracker/default.nix
  29. 2
      pkgs/applications/misc/khal/default.nix
  30. 2
      pkgs/applications/misc/khard/default.nix
  31. 2
      pkgs/applications/misc/loxodo/default.nix
  32. 2
      pkgs/applications/misc/ocropus/default.nix
  33. 2
      pkgs/applications/misc/octoprint/default.nix
  34. 2
      pkgs/applications/misc/octoprint/plugins.nix
  35. 2
      pkgs/applications/misc/pdfdiff/default.nix
  36. 4
      pkgs/applications/misc/pitz/default.nix
  37. 2
      pkgs/applications/misc/printrun/default.nix
  38. 2
      pkgs/applications/misc/pytrainer/default.nix
  39. 4
      pkgs/applications/misc/ranger/default.nix
  40. 2
      pkgs/applications/misc/rtv/default.nix
  41. 2
      pkgs/applications/misc/solaar/default.nix
  42. 2
      pkgs/applications/misc/zscroll/default.nix
  43. 4
      pkgs/applications/networking/browsers/qutebrowser/default.nix
  44. 2
      pkgs/applications/networking/feedreaders/canto-curses/default.nix
  45. 2
      pkgs/applications/networking/feedreaders/canto-daemon/default.nix
  46. 2
      pkgs/applications/networking/feedreaders/rawdog/default.nix
  47. 2
      pkgs/applications/networking/instant-messengers/blink/default.nix
  48. 4
      pkgs/applications/networking/mailreaders/mailnag/default.nix
  49. 2
      pkgs/applications/networking/mailreaders/mailpile/default.nix
  50. 4
      pkgs/applications/office/keepnote/default.nix
  51. 4
      pkgs/applications/office/zim/default.nix
  52. 4
      pkgs/applications/science/spyder/default.nix
  53. 2
      pkgs/applications/version-management/git-and-tools/git-cola/default.nix
  54. 2
      pkgs/applications/version-management/git-review/default.nix
  55. 4
      pkgs/applications/version-management/gitinspector/default.nix
  56. 4
      pkgs/applications/version-management/meld/default.nix
  57. 2
      pkgs/applications/version-management/peru/default.nix
  58. 2
      pkgs/applications/version-management/rabbitvcs/default.nix
  59. 2
      pkgs/applications/version-management/tailor/default.nix
  60. 2
      pkgs/applications/version-management/tortoisehg/default.nix
  61. 4
      pkgs/applications/video/devede/default.nix
  62. 2
      pkgs/applications/video/kazam/default.nix
  63. 4
      pkgs/applications/video/key-mon/default.nix
  64. 4
      pkgs/applications/video/miro/default.nix
  65. 2
      pkgs/applications/virtualization/openstack/glance.nix
  66. 2
      pkgs/applications/virtualization/openstack/keystone.nix
  67. 2
      pkgs/applications/virtualization/openstack/neutron.nix
  68. 2
      pkgs/applications/virtualization/openstack/nova.nix
  69. 2
      pkgs/applications/virtualization/virt-manager/default.nix
  70. 4
      pkgs/applications/window-managers/qtile/default.nix
  71. 4
      pkgs/development/arduino/ino/default.nix
  72. 4
      pkgs/development/tools/build-managers/buildbot-slave/default.nix
  73. 4
      pkgs/development/tools/build-managers/buildbot/default.nix
  74. 2
      pkgs/development/tools/devpi-client/default.nix
  75. 4
      pkgs/development/tools/grabserial/default.nix
  76. 2
      pkgs/development/tools/misc/nixbang/default.nix
  77. 2
      pkgs/development/tools/misc/ycmd/default.nix
  78. 2
      pkgs/development/tools/profiling/gprof2dot/default.nix
  79. 4
      pkgs/development/tools/winpdb/default.nix
  80. 4
      pkgs/games/mnemosyne/default.nix
  81. 2
      pkgs/misc/frescobaldi/default.nix
  82. 4
      pkgs/os-specific/linux/iotop/default.nix
  83. 6
      pkgs/servers/matrix-synapse/default.nix
  84. 2
      pkgs/shells/xonsh/default.nix
  85. 2
      pkgs/tools/X11/arandr/default.nix
  86. 4
      pkgs/tools/X11/winswitch/default.nix
  87. 4
      pkgs/tools/X11/xpra/default.nix
  88. 4
      pkgs/tools/X11/xpra/gtk3.nix
  89. 4
      pkgs/tools/admin/cli53/default.nix
  90. 2
      pkgs/tools/admin/letsencrypt/default.nix
  91. 2
      pkgs/tools/admin/simp_le/default.nix
  92. 4
      pkgs/tools/audio/beets/alternatives-plugin.nix
  93. 6
      pkgs/tools/audio/beets/default.nix
  94. 2
      pkgs/tools/backup/attic/default.nix
  95. 2
      pkgs/tools/backup/borg/default.nix
  96. 2
      pkgs/tools/backup/obnam/default.nix
  97. 2
      pkgs/tools/backup/s3ql/default.nix
  98. 2
      pkgs/tools/backup/wal-e/default.nix
  99. 2
      pkgs/tools/compression/dtrx/default.nix
  100. 4
      pkgs/tools/filesystems/gitfs/default.nix

4
pkgs/applications/audio/gpodder/default.nix

@ -1,9 +1,9 @@
{ stdenv, fetchurl, buildPythonPackage, pythonPackages, mygpoclient, intltool
{ stdenv, fetchurl, buildPythonApplication, pythonPackages, mygpoclient, intltool
, ipodSupport ? true, libgpod
, gnome3
}:
buildPythonPackage rec {
buildPythonApplication rec {
name = "gpodder-${version}";
namePrefix = "";

2
pkgs/applications/audio/gtklick/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, pythonPackages, gettext, klick}:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "gtklick-${version}";
namePrefix = "";
version = "0.6.4";

2
pkgs/applications/audio/lastfmsubmitd/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, pythonPackages }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "lastfmsubmitd-${version}";
namePrefix = "";
version = "1.0.6";

2
pkgs/applications/audio/lastwatch/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchgit, pythonPackages }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "lastwatch-${version}";
namePrefix = "";
version = "0.4.1";

2
pkgs/applications/audio/mimms/default.nix

@ -2,7 +2,7 @@
let version = "3.2";
in
pythonPackages.buildPythonPackage {
pythonPackages.buildPythonApplication {
name = "mimms-${version}";
src = fetchurl {
url = "http://download.savannah.gnu.org/releases/mimms/mimms-${version}.tar.bz2";

2
pkgs/applications/audio/mopidy-gmusic/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, pythonPackages, mopidy }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "mopidy-gmusic-${version}";
version = "1.0.0";

2
pkgs/applications/audio/mopidy-moped/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, pythonPackages, mopidy }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "mopidy-moped-${version}";
version = "0.6.0";

2
pkgs/applications/audio/mopidy-mopify/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, pythonPackages, mopidy }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "mopidy-mopify-${version}";
version = "1.5.8";

2
pkgs/applications/audio/mopidy-musicbox-webclient/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchFromGitHub, pythonPackages, mopidy }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "mopidy-musicbox-webclient-${version}";
version = "2.0.0";

2
pkgs/applications/audio/mopidy-soundcloud/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchFromGitHub, pythonPackages, mopidy }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "mopidy-soundcloud-${version}";
version = "2.0.2";

2
pkgs/applications/audio/mopidy-spotify-tunigo/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchFromGitHub, pythonPackages, mopidy, mopidy-spotify }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "mopidy-spotify-tunigo-${version}";
version = "0.2.1";

2
pkgs/applications/audio/mopidy-spotify/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, pythonPackages, mopidy }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "mopidy-spotify-${version}";
version = "2.3.1";

2
pkgs/applications/audio/mopidy-youtube/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchFromGitHub, pythonPackages, mopidy }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "mopidy-youtube-${version}";
version = "2.0.1";

2
pkgs/applications/audio/mopidy/default.nix

@ -2,7 +2,7 @@
, glib_networking, gst_plugins_good, gst_plugins_base, gst_plugins_ugly
}:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "mopidy-${version}";
version = "1.1.2";

4
pkgs/applications/audio/picard/default.nix

@ -1,10 +1,10 @@
{ stdenv, buildPythonPackage, fetchurl, gettext
{ stdenv, buildPythonApplication, fetchurl, gettext
, pkgconfig, libofa, ffmpeg, chromaprint
, pyqt4, mutagen, python-libdiscid
}:
let version = "1.3.2"; in
buildPythonPackage {
buildPythonApplication {
name = "picard-${version}";
namePrefix = "";

2
pkgs/applications/audio/pithos/default.nix

@ -1,7 +1,7 @@
{ fetchFromGitHub, stdenv, pythonPackages, gtk3, gobjectIntrospection, libnotify
, gst_all_1, wrapGAppsHook }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
pname = "pithos";
version = "1.1.2";
name = "${pname}-${version}";

4
pkgs/applications/audio/quodlibet/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, python, buildPythonPackage, mutagen, pygtk, pygobject, intltool
{ stdenv, fetchurl, python, buildPythonApplication, mutagen, pygtk, pygobject, intltool
, pythonDBus, gst_python, withGstPlugins ? false, gst_plugins_base ? null
, gst_plugins_good ? null, gst_plugins_ugly ? null, gst_plugins_bad ? null }:
@ -9,7 +9,7 @@ assert withGstPlugins -> gst_plugins_base != null
let version = "2.6.3"; in
buildPythonPackage {
buildPythonApplication {
# call the package quodlibet and just quodlibet
name = "quodlibet-${version}"
+ stdenv.lib.optionalString withGstPlugins "-with-gst-plugins";

4
pkgs/applications/audio/sonata/default.nix

@ -1,11 +1,11 @@
{ pkgs, stdenv, fetchFromGitHub, pkgconfig, intltool, wrapGAppsHook,
python, buildPythonPackage, isPy3k,
python, buildPythonApplication, isPy3k,
gnome3, gtk3, gobjectIntrospection,
dbus, pygobject3, mpd2 }:
with pkgs.lib;
buildPythonPackage rec {
buildPythonApplication rec {
name = "sonata-${version}";
version = "1.7b1";
namePrefix = "";

2
pkgs/applications/editors/leo-editor/default.nix

@ -1,6 +1,6 @@
{ stdenv, pythonPackages, fetchgit }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "leo-editor-${version}";
namePrefix = "";
version = "5.1";

4
pkgs/applications/editors/nvpy/default.nix

@ -1,6 +1,6 @@
{ pkgs, fetchurl, tk, buildPythonPackage, pythonPackages }:
{ pkgs, fetchurl, tk, buildPythonApplication, pythonPackages }:
buildPythonPackage rec {
buildPythonApplication rec {
version = "0.9.2";
name = "nvpy-${version}";

4
pkgs/applications/graphics/jbrout/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchsvn, buildPythonPackage, python, pyGtkGlade, makeWrapper, pyexiv2, pythonPackages, fbida, which }:
{ stdenv, fetchsvn, buildPythonApplication, python, pyGtkGlade, makeWrapper, pyexiv2, pythonPackages, fbida, which }:
buildPythonPackage rec {
buildPythonApplication rec {
name = "jbrout-${version}";
version = "338";

4
pkgs/applications/graphics/mcomix/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, buildPythonPackage, python27Packages }:
{ stdenv, fetchurl, buildPythonApplication, python27Packages }:
buildPythonPackage rec {
buildPythonApplication rec {
namePrefix = "";
name = "mcomix-1.01";

4
pkgs/applications/graphics/mirage/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, buildPythonPackage, python, pygtk, pillow, libX11, gettext }:
{ stdenv, fetchurl, buildPythonApplication, python, pygtk, pillow, libX11, gettext }:
buildPythonPackage rec {
buildPythonApplication rec {
namePrefix = "";
name = "mirage-0.9.5.2";

2
pkgs/applications/misc/bleachbit/default.nix

@ -1,5 +1,5 @@
{ stdenv, pythonPackages, fetchurl }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "bleachbit-${version}";
version = "1.8";

4
pkgs/applications/misc/electrum-dash/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, buildPythonPackage, pythonPackages, slowaes }:
{ stdenv, fetchurl, buildPythonApplication, pythonPackages, slowaes }:
buildPythonPackage rec {
buildPythonApplication rec {
name = "electrum-dash-${version}";
version = "2.4.1";

4
pkgs/applications/misc/electrum/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, buildPythonPackage, pythonPackages, slowaes }:
{ stdenv, fetchurl, buildPythonApplication, pythonPackages, slowaes }:
buildPythonPackage rec {
buildPythonApplication rec {
name = "electrum-${version}";
version = "2.5.4";

4
pkgs/applications/misc/gramps/default.nix

@ -1,7 +1,7 @@
{ stdenv, fetchurl, gtk3, pythonPackages, python, pycairo, pygobject3, intltool,
pango, gsettings_desktop_schemas }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
version = "4.1.1";
name = "gramps-${version}";
namePrefix = "";
@ -18,7 +18,7 @@ pythonPackages.buildPythonPackage rec {
pythonPath = [ pygobject3 pango pycairo pythonPackages.bsddb ];
# Same installPhase as in buildPythonPackage but without --old-and-unmanageble
# Same installPhase as in buildPythonApplication but without --old-and-unmanageble
# install flag.
installPhase = ''
runHook preInstall

4
pkgs/applications/misc/hamster-time-tracker/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchzip, buildPythonPackage, docbook2x, libxslt, gnome_doc_utils
{ stdenv, fetchzip, buildPythonApplication, docbook2x, libxslt, gnome_doc_utils
, intltool, dbus_glib, pygobject, pygtk, pyxdg, gnome_python, dbus, sqlite3
, hicolor_icon_theme
}:
@ -8,7 +8,7 @@
#
# WARNING:root:Could not import wnck - workspace tracking will be disabled
buildPythonPackage rec {
buildPythonApplication rec {
name = "hamster-time-tracker-1.04";
namePrefix = "";

2
pkgs/applications/misc/khal/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, pkgs, pythonPackages }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
version = "0.7.0";
name = "khal-${version}";

2
pkgs/applications/misc/khard/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, pkgs, pythonPackages }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
version = "0.8.1";
name = "khard-${version}";
namePrefix = "";

2
pkgs/applications/misc/loxodo/default.nix

@ -3,7 +3,7 @@ let
py = python27Packages;
python = py.python;
in
py.buildPythonPackage rec {
py.buildPythonApplication rec {
name = "loxodo-0.20150124";
src = fetchgit {

2
pkgs/applications/misc/ocropus/default.nix

@ -17,7 +17,7 @@ let
];
in
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "ocropus-${version}";
version = "20150316";

2
pkgs/applications/misc/octoprint/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchFromGitHub, pythonPackages }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "OctoPrint-${version}";
version = "1.2.9";

2
pkgs/applications/misc/octoprint/plugins.nix

@ -1,7 +1,7 @@
{ stdenv, fetchFromGitHub, octoprint, pythonPackages }:
let
buildPlugin = args: pythonPackages.buildPythonPackage (args // {
buildPlugin = args: pythonPackages.buildPythonApplication (args // {
buildInputs = (args.buildInputs or []) ++ [ octoprint ];
});
in {

2
pkgs/applications/misc/pdfdiff/default.nix

@ -2,7 +2,7 @@
let
py = pythonPackages;
in
py.buildPythonPackage rec {
py.buildPythonApplication rec {
name = "pdfdiff-${version}";
version = "0.92";

4
pkgs/applications/misc/pitz/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, buildPythonPackage, tempita, jinja2, pyyaml, clepy, mock
{ stdenv, fetchurl, buildPythonApplication, tempita, jinja2, pyyaml, clepy, mock
, nose, decorator, docutils
}:
@ -11,7 +11,7 @@
# pitz-shell is not the primary interface, so it is not critical to have it
# working. Concider fixing pitz upstream.
buildPythonPackage rec {
buildPythonApplication rec {
name = "pitz-1.2.4";
namePrefix = "";

2
pkgs/applications/misc/printrun/default.nix

@ -1,6 +1,6 @@
{ stdenv, python27Packages, fetchFromGitHub }:
python27Packages.buildPythonPackage rec {
python27Packages.buildPythonApplication rec {
name = "printrun-20150310";
src = fetchFromGitHub {

2
pkgs/applications/misc/pytrainer/default.nix

@ -11,7 +11,7 @@ let
in
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "pytrainer-${version}";
version = "1.10.0";

4
pkgs/applications/misc/ranger/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, buildPythonPackage, python, w3m, file }:
{ stdenv, fetchurl, buildPythonApplication, python, w3m, file }:
buildPythonPackage rec {
buildPythonApplication rec {
name = "ranger-1.7.2";
meta = {

2
pkgs/applications/misc/rtv/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchFromGitHub, pkgs, lib, python, pythonPackages }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
version = "1.8.0";
name = "rtv-${version}";

2
pkgs/applications/misc/solaar/default.nix

@ -1,5 +1,5 @@
{fetchurl, stdenv, gtk3, python34Packages, gobjectIntrospection}:
python34Packages.buildPythonPackage rec {
python34Packages.buildPythonApplication rec {
name = "solaar-${version}";
version = "0.9.2";
namePrefix = "";

2
pkgs/applications/misc/zscroll/default.nix

@ -2,7 +2,7 @@
let version = "1.0"; in
python3Packages.buildPythonPackage {
python3Packages.buildPythonApplication {
name = "zscroll-${version}";
# don't prefix with python version
namePrefix = "";

4
pkgs/applications/networking/browsers/qutebrowser/default.nix

@ -1,10 +1,10 @@
{ stdenv, fetchurl, python, buildPythonPackage, qtmultimedia, pyqt5
{ stdenv, fetchurl, python, buildPythonApplication, qtmultimedia, pyqt5
, jinja2, pygments, pyyaml, pypeg2, gst-plugins-base, gst-plugins-good
, gst-plugins-bad, gst-libav, wrapGAppsHook, glib_networking }:
let version = "0.5.1"; in
buildPythonPackage rec {
buildPythonApplication rec {
name = "qutebrowser-${version}";
namePrefix = "";

2
pkgs/applications/networking/feedreaders/canto-curses/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchFromGitHub, python34Packages, readline, ncurses, canto-daemon }:
python34Packages.buildPythonPackage rec {
python34Packages.buildPythonApplication rec {
version = "0.9.6";
name = "canto-curses-${version}";

2
pkgs/applications/networking/feedreaders/canto-daemon/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchFromGitHub, python34Packages, }:
python34Packages.buildPythonPackage rec {
python34Packages.buildPythonApplication rec {
version = "0.9.5";
name = "canto-daemon-${version}";
namePrefix = "";

2
pkgs/applications/networking/feedreaders/rawdog/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, pythonPackages }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "rawdog-${version}";
version = "2.21";

2
pkgs/applications/networking/instant-messengers/blink/default.nix

@ -1,7 +1,7 @@
{ stdenv, fetchurl, pythonPackages, pyqt4, cython, libvncserver, zlib, twisted
, gnutls, libvpx }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "blink-${version}";
version = "1.4.2";

4
pkgs/applications/networking/mailreaders/mailnag/default.nix

@ -1,9 +1,9 @@
{ stdenv, buildPythonPackage, fetchurl, gettext, gtk3, pythonPackages
{ stdenv, buildPythonApplication, fetchurl, gettext, gtk3, pythonPackages
, gdk_pixbuf, libnotify, gst_all_1
, libgnome_keyring3 ? null, networkmanager ? null
}:
buildPythonPackage rec {
buildPythonApplication rec {
name = "mailnag-${version}";
version = "1.1.0";

2
pkgs/applications/networking/mailreaders/mailpile/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchgit, pythonPackages, gnupg1orig, makeWrapper, openssl }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "mailpile-${version}";
version = "0.4.1";

4
pkgs/applications/office/keepnote/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, buildPythonPackage, pythonPackages, pygtk }:
{ stdenv, fetchurl, buildPythonApplication, pythonPackages, pygtk }:
buildPythonPackage {
buildPythonApplication {
name = "keepnote-0.7.8";
namePrefix = "";

4
pkgs/applications/office/zim/default.nix

@ -1,4 +1,4 @@
{ stdenv, lib, fetchurl, buildPythonPackage, pythonPackages, pygtk, pygobject, python }:
{ stdenv, lib, fetchurl, buildPythonApplication, pythonPackages, pygtk, pygobject, python }:
#
# TODO: Declare configuration options for the following optional dependencies:
@ -7,7 +7,7 @@
# - pyxdg: Need to make it work first (see setupPyInstallFlags).
#
buildPythonPackage rec {
buildPythonApplication rec {
name = "zim-${version}";
version = "0.63";
namePrefix = "";

4
pkgs/applications/science/spyder/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, unzip, buildPythonPackage, makeDesktopItem
{ stdenv, fetchurl, unzip, buildPythonApplication, makeDesktopItem
# mandatory
, pyside
# recommended
@ -7,7 +7,7 @@
, ipython ? null, pylint ? null, pep8 ? null
}:
buildPythonPackage rec {
buildPythonApplication rec {
name = "spyder-${version}";
version = "2.3.8";
namePrefix = "";

2
pkgs/applications/version-management/git-and-tools/git-cola/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, python, pythonPackages, makeWrapper, gettext }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "git-cola-${version}";
version = "2.2.1";

2
pkgs/applications/version-management/git-review/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, pythonPackages, python} :
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "git-review-${version}";
version = "1.25.0";

4
pkgs/applications/version-management/gitinspector/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchzip, buildPythonPackage }:
{ stdenv, fetchzip, buildPythonApplication }:
buildPythonPackage rec {
buildPythonApplication rec {
name = "gitinspector-${version}";
version = "0.4.1";
namePrefix = "";

4
pkgs/applications/version-management/meld/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, itstool, buildPythonPackage, python27, intltool, makeWrapper
{ stdenv, fetchurl, itstool, buildPythonApplication, python27, intltool, makeWrapper
, libxml2, pygobject3, gobjectIntrospection, gtk3, gnome3, pycairo, cairo
}:
@ -8,7 +8,7 @@ let
version = "${minor}.0";
in
buildPythonPackage rec {
buildPythonApplication rec {
name = "meld-${version}";
namePrefix = "";

2
pkgs/applications/version-management/peru/default.nix

@ -4,7 +4,7 @@ let
version = "0.2.3";
in
python3Packages.buildPythonPackage rec {
python3Packages.buildPythonApplication rec {
# Do not prefix name with python specific version identifier.
namePrefix = "";

2
pkgs/applications/version-management/rabbitvcs/default.nix

@ -1,5 +1,5 @@
{ fetchFromGitHub, lib, python2Packages, meld, subversion, gvfs, xdg_utils }:
python2Packages.buildPythonPackage rec {
python2Packages.buildPythonApplication rec {
name = "rabbitvcs-${version}";
version = "0.16";
namePrefix = "";

2
pkgs/applications/version-management/tailor/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, pythonPackages }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "tailor-${version}";
version = "0.9.35";

2
pkgs/applications/version-management/tortoisehg/default.nix

@ -1,6 +1,6 @@
{ pkgs, lib, mercurial, pyPackages ? pkgs.python27Packages }:
pkgs.buildPythonPackage rec {
pkgs.buildPythonApplication rec {
name = "tortoisehg-${version}";
version = "3.6";
namePrefix = "";

4
pkgs/applications/video/devede/default.nix

@ -1,9 +1,9 @@
{ pkgs, stdenv, fetchurl, pythonPackages, buildPythonPackage, pygtk, ffmpeg, mplayer, vcdimager, cdrkit, dvdauthor }:
{ pkgs, stdenv, fetchurl, pythonPackages, buildPythonApplication, pygtk, ffmpeg, mplayer, vcdimager, cdrkit, dvdauthor }:
let
inherit (pythonPackages) dbus;
in buildPythonPackage rec {
in buildPythonApplication rec {
name = "devede-3.23.0";
namePrefix = "";

2
pkgs/applications/video/kazam/default.nix

@ -2,7 +2,7 @@
, gtk3, libwnck3, keybinder, intltool, libcanberra }:
python3Packages.buildPythonPackage rec {
python3Packages.buildPythonApplication rec {
name = "kazam-${version}";
version = "1.4.3";
namePrefix = "";

4
pkgs/applications/video/key-mon/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, buildPythonPackage, gnome, librsvg, pygtk, pythonPackages }:
{ stdenv, fetchurl, buildPythonApplication, gnome, librsvg, pygtk, pythonPackages }:
buildPythonPackage rec {
buildPythonApplication rec {
name = "key-mon-${version}";
version = "1.17";
namePrefix = "";

4
pkgs/applications/video/miro/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, python, buildPythonPackage, pythonPackages, pkgconfig
{ stdenv, fetchurl, python, buildPythonApplication, pythonPackages, pkgconfig
, pyrex096, ffmpeg, boost, glib, pygobject, gtk2, webkitgtk2, libsoup, pygtk
, taglib, sqlite, pycurl, mutagen, pycairo, pythonDBus, pywebkitgtk
, libtorrentRasterbar, glib_networking, gsettings_desktop_schemas
@ -10,7 +10,7 @@ assert enableBonjour -> avahi != null;
with stdenv.lib;
buildPythonPackage rec {
buildPythonApplication rec {
name = "miro-${version}";
namePrefix = "";
version = "6.0";

2
pkgs/applications/virtualization/openstack/glance.nix

@ -1,7 +1,7 @@
{ stdenv, fetchurl, pythonPackages, sqlite, which, strace }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "glance-${version}";
version = "11.0.0";
namePrefix = "";

2
pkgs/applications/virtualization/openstack/keystone.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, pythonPackages, xmlsec, which, openssl }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "keystone-${version}";
version = "8.0.0";
namePrefix = "";

2
pkgs/applications/virtualization/openstack/neutron.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, pythonPackages, xmlsec, which, dnsmasq }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "neutron-${version}";
version = "7.0.0";
namePrefix = "";

2
pkgs/applications/virtualization/openstack/nova.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, pythonPackages, openssl, openssh }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "nova-${version}";
version = "12.0.0";
namePrefix = "";

2
pkgs/applications/virtualization/virt-manager/default.nix

@ -7,7 +7,7 @@
with stdenv.lib;
with pythonPackages;
buildPythonPackage rec {
buildPythonApplication rec {
name = "virt-manager-${version}";
version = "1.3.1";
namePrefix = "";

4
pkgs/applications/window-managers/qtile/default.nix

@ -1,11 +1,11 @@
{ stdenv, fetchFromGitHub, buildPythonPackage, python27Packages, pkgs }:
{ stdenv, fetchFromGitHub, buildPythonApplication, python27Packages, pkgs }:
let cairocffi-xcffib = python27Packages.cairocffi.override {
pythonPath = [ python27Packages.xcffib ];
};
in
buildPythonPackage rec {
buildPythonApplication rec {
name = "qtile-${version}";
version = "0.10.4";

4
pkgs/development/arduino/ino/default.nix

@ -1,7 +1,7 @@
{ stdenv, fetchurl, buildPythonPackage, pythonPackages, picocom
{ stdenv, fetchurl, buildPythonApplication, pythonPackages, picocom
, avrdude, arduino-core, avrgcclibc }:
buildPythonPackage rec {
buildPythonApplication rec {
name = "ino-0.3.6";
namePrefix = "";

4
pkgs/development/tools/build-managers/buildbot-slave/default.nix

@ -1,6 +1,6 @@
{ stdenv, buildPythonPackage, fetchurl, coreutils, twisted }:
{ stdenv, buildPythonApplication, fetchurl, coreutils, twisted }:
buildPythonPackage (rec {
buildPythonApplication (rec {
name = "buildbot-slave-0.8.10";
namePrefix = "";

4
pkgs/development/tools/build-managers/buildbot/default.nix

@ -1,4 +1,4 @@
{ stdenv, buildPythonPackage, fetchurl, twisted, dateutil, jinja2
{ stdenv, buildPythonApplication, fetchurl, twisted, dateutil, jinja2
, sqlalchemy , sqlalchemy_migrate_0_7
, enableDebugClient ? false, pygobject ? null, pyGtkGlade ? null
}:
@ -8,7 +8,7 @@
assert enableDebugClient -> pygobject != null && pyGtkGlade != null;
buildPythonPackage (rec {
buildPythonApplication (rec {
name = "buildbot-0.8.12";
namePrefix = "";

2
pkgs/development/tools/devpi-client/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, pythonPackages, python} :
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "devpi-client-${version}";
version = "2.3.2";

4
pkgs/development/tools/grabserial/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchgit, buildPythonPackage, pythonPackages }:
{ stdenv, fetchgit, buildPythonApplication, pythonPackages }:
buildPythonPackage rec {
buildPythonApplication rec {
name = "grabserial-20141120";
namePrefix = "";

2
pkgs/development/tools/misc/nixbang/default.nix

@ -1,7 +1,7 @@
{ lib, pythonPackages, fetchFromGitHub }:
let version = "0.1.2"; in
pythonPackages.buildPythonPackage {
pythonPackages.buildPythonApplication {
name = "nixbang-${version}";
namePrefix = "";

2
pkgs/development/tools/misc/ycmd/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchgit, cmake, python, llvmPackages, boost, pythonPackages, buildPythonPackage, makeWrapper
{ stdenv, fetchgit, cmake, python, llvmPackages, boost, pythonPackages, buildPythonApplication, makeWrapper
}:
stdenv.mkDerivation rec {

2
pkgs/development/tools/profiling/gprof2dot/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchFromGitHub, pythonPackages }:
pythonPackages.buildPythonPackage {
pythonPackages.buildPythonApplication {
name = "gprof2dot-2015-04-27";
src = fetchFromGitHub {

4
pkgs/development/tools/winpdb/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, buildPythonPackage, wxPython, makeDesktopItem }:
{ stdenv, fetchurl, buildPythonApplication, wxPython, makeDesktopItem }:
buildPythonPackage rec {
buildPythonApplication rec {
name = "winpdb-1.4.8";
namePrefix = "";

4
pkgs/games/mnemosyne/default.nix

@ -1,12 +1,12 @@
{ stdenv
, fetchurl
, buildPythonPackage
, buildPythonApplication
, pyqt4
, pythonPackages
}:
let
version = "2.3.2";
in buildPythonPackage rec {
in buildPythonApplication rec {
name = "mnemosyne-${version}";
src = fetchurl {
url = "http://sourceforge.net/projects/mnemosyne-proj/files/mnemosyne/${name}/Mnemosyne-${version}.tar.gz";

2
pkgs/misc/frescobaldi/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, pythonPackages, lilypond, pyqt4, pygame }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "frescobaldi-${version}";
version = "2.0.16";

4
pkgs/os-specific/linux/iotop/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, buildPythonPackage, pythonPackages }:
{ stdenv, fetchurl, buildPythonApplication, pythonPackages }:
buildPythonPackage rec {
buildPythonApplication rec {
name = "iotop-0.6";
namePrefix = "";

6
pkgs/servers/matrix-synapse/default.nix

@ -1,6 +1,6 @@
{ pkgs, stdenv, buildPythonPackage, pythonPackages, fetchurl, fetchFromGitHub }:
{ pkgs, stdenv, buildPythonApplication, pythonPackages, fetchurl, fetchFromGitHub }:
let
matrix-angular-sdk = buildPythonPackage rec {
matrix-angular-sdk = buildPythonApplication rec {
name = "matrix-angular-sdk-${version}";
version = "0.6.6";
@ -10,7 +10,7 @@ let
};
};
in
buildPythonPackage rec {
buildPythonApplication rec {
name = "matrix-synapse-${version}";
version = "0.12.0";

2
pkgs/shells/xonsh/default.nix

@ -1,6 +1,6 @@
{stdenv, fetchFromGitHub, python3Packages}:
python3Packages.buildPythonPackage rec {
python3Packages.buildPythonApplication rec {
name = "xonsh-${version}";
version = "0.1.3";

2
pkgs/tools/X11/arandr/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, python, xrandr, pythonPackages }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "arandr-0.1.8";
src = fetchurl {

4
pkgs/tools/X11/winswitch/default.nix

@ -1,8 +1,8 @@
{ stdenv, fetchurl, buildPythonPackage, pythonPackages
{ stdenv, fetchurl, buildPythonApplication, pythonPackages
, which, xpra, xmodmap }:
let
base = buildPythonPackage rec {
base = buildPythonApplication rec {
name = "winswitch-${version}";
namePrefix = "";
version = "0.12.16";

4
pkgs/tools/X11/xpra/default.nix

@ -1,11 +1,11 @@
{ stdenv, fetchurl, buildPythonPackage, pythonPackages
{ stdenv, fetchurl, buildPythonApplication, pythonPackages
, python, cython, pkgconfig
, xorg, gtk, glib, pango, cairo, gdk_pixbuf, atk, pycairo
, makeWrapper, xkbcomp, xorgserver, getopt, xauth, utillinux, which, fontsConf, xkeyboard_config
, ffmpeg, x264, libvpx, libwebp
, libfakeXinerama }:
buildPythonPackage rec {
buildPythonApplication rec {
name = "xpra-0.15.3";
namePrefix = "";

4
pkgs/tools/X11/xpra/gtk3.nix

@ -1,11 +1,11 @@
{ stdenv, fetchurl, buildPythonPackage
{ stdenv, fetchurl, buildPythonApplication
, python, cython, pkgconfig
, xorg, gtk3, glib, pango, cairo, gdk_pixbuf, atk, pygobject3, pycairo, gobjectIntrospection
, makeWrapper, xkbcomp, xorgserver, getopt, xauth, utillinux, which, fontsConf, xkeyboard_config
, ffmpeg, x264, libvpx, libwebp
, libfakeXinerama }:
buildPythonPackage rec {
buildPythonApplication rec {
name = "xpra-0.14.19";
namePrefix = "";

4
pkgs/tools/admin/cli53/default.nix

@ -1,6 +1,6 @@
{ lib, buildPythonPackage, pythonPackages, fetchurl }:
{ lib, buildPythonApplication, pythonPackages, fetchurl }:
buildPythonPackage rec {
buildPythonApplication rec {
name = "cli53-${version}";
namePrefix = ""; # Suppress "python27-" name prefix
version = "0.4.4";

2
pkgs/tools/admin/letsencrypt/default.nix

@ -1,6 +1,6 @@
{ stdenv, pythonPackages, fetchurl, dialog }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
version = "0.1.0";
name = "letsencrypt-${version}";

2
pkgs/tools/admin/simp_le/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchFromGitHub, pythonPackages }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "simp_le-2016-01-09";
src = fetchFromGitHub {

4
pkgs/tools/audio/beets/alternatives-plugin.nix

@ -1,6 +1,6 @@
{ stdenv, buildPythonPackage, fetchFromGitHub, pythonPackages }:
{ stdenv, buildPythonApplication, fetchFromGitHub, pythonPackages }:
buildPythonPackage rec {
buildPythonApplication rec {
name = "beets-alternatives-${version}";
version = "0.8.2";

6
pkgs/tools/audio/beets/default.nix

@ -1,5 +1,5 @@
{ stdenv, fetchFromGitHub, writeScript, glibcLocales
, buildPythonPackage, pythonPackages, python, imagemagick
, buildPythonApplication, pythonPackages, python, imagemagick
, enableAcousticbrainz ? true
, enableAcoustid ? true
@ -68,7 +68,7 @@ let
testShell = "${bashInteractive}/bin/bash --norc";
completion = "${bashCompletion}/share/bash-completion/bash_completion";
in buildPythonPackage rec {
in buildPythonApplication rec {
name = "beets-${version}";
version = "1.3.17";
namePrefix = "";
@ -103,7 +103,7 @@ in buildPythonPackage rec {
++ optional enableThumbnails pythonPackages.pyxdg
++ optional enableWeb pythonPackages.flask
++ optional enableAlternatives (import ./alternatives-plugin.nix {
inherit stdenv buildPythonPackage pythonPackages fetchFromGitHub;
inherit stdenv buildPythonApplication pythonPackages fetchFromGitHub;
});
buildInputs = with pythonPackages; [

2
pkgs/tools/backup/attic/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchzip, python3Packages, openssl, acl }:
python3Packages.buildPythonPackage rec {
python3Packages.buildPythonApplication rec {
name = "attic-${version}";
version = "0.16";
namePrefix = "";

2
pkgs/tools/backup/borg/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, python3Packages, acl, lz4, openssl }:
python3Packages.buildPythonPackage rec {
python3Packages.buildPythonApplication rec {
name = "borgbackup-${version}";
version = "0.30.0";
namePrefix = "";

2
pkgs/tools/backup/obnam/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, python, pythonPackages, pycrypto, attr }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "obnam-${version}";
version = "1.19.1";

2
pkgs/tools/backup/s3ql/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, python3Packages, sqlite }:
python3Packages.buildPythonPackage rec {
python3Packages.buildPythonApplication rec {
name = "${pname}-${version}";
pname = "s3ql";
version = "2.13";

2
pkgs/tools/backup/wal-e/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, pythonPackages, lzop, postgresql, pv }:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "wal-e-${version}";
version = "0.6.10";

2
pkgs/tools/compression/dtrx/default.nix

@ -1,6 +1,6 @@
{stdenv, fetchurl, pythonPackages}:
pythonPackages.buildPythonPackage rec {
pythonPackages.buildPythonApplication rec {
name = "dtrx-${version}";
version = "7.1";

4
pkgs/tools/filesystems/gitfs/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchFromGitHub, python, buildPythonPackage, pythonPackages }:
{ stdenv, fetchFromGitHub, python, buildPythonApplication, pythonPackages }:
buildPythonPackage rec {
buildPythonApplication rec {
name = "gitfs-0.2.5";
src = fetchFromGitHub {

Some files were not shown because too many files changed in this diff

Loading…
Cancel
Save