Browse Source

Merge staging-next into master (#44009)

* substitute(): --subst-var was silently coercing to "" if the variable does not exist.

* libffi: simplify using `checkInputs`

* pythonPackges.hypothesis, pythonPackages.pytest: simpify dependency cycle fix

* utillinux: 2.32 -> 2.32.1

https://lkml.org/lkml/2018/7/16/532

* busybox: 1.29.0 -> 1.29.1

* bind: 9.12.1-P2 -> 9.12.2

https://ftp.isc.org/isc/bind9/9.12.2/RELEASE-NOTES-bind-9.12.2.html

* curl: 7.60.0 -> 7.61.0

* gvfs: make tests run, but disable

* ilmbase: disable tests on i686. Spooky!

* mdds: fix tests

* git: disable checks as tests are run in installcheck

* ruby: disable tests

* libcommuni: disable checks as tests are run in installcheck

* librdf: make tests run, but disable

* neon, neon_0_29: make tests run, but disable

* pciutils: 3.6.0 -> 3.6.1

Semi-automatic update generated by https://github.com/ryantm/nixpkgs-update tools. This update was made based on information from https://repology.org/metapackage/pciutils/versions.

* mesa: more include fixes

mostly from void-linux (thanks!)

* npth: 1.5 -> 1.6

minor bump

* boost167: Add lockfree next_prior patch

* stdenv: cleanup darwin bootstrapping

Also gets rid of the full python and some of it's dependencies in the
stdenv build closure.

* Revert "pciutils: use standardized equivalent for canonicalize_file_name"

This reverts commit f8db20fb3a.
Patching should no longer be needed with 3.6.1.

* binutils-wrapper: Try to avoid adding unnecessary -L flags

(cherry picked from commit f3758258b8895508475caf83e92bfb236a27ceb9)
Signed-off-by: Domen Kožar <domen@dev.si>

* libffi: don't check on darwin

libffi usages in stdenv broken darwin. We need to disable doCheck for that case.

* "rm $out/share/icons/hicolor/icon-theme.cache" -> hicolor-icon-theme setup-hook

* python.pkgs.pytest: setupHook to prevent creation of .pytest-cache folder, fixes #40273

When `py.test` was run with a folder as argument, it would not only
search for tests in that folder, but also create a .pytest-cache folder.
Not only is this state we don't want, but it was also causing
collisions.

* parity-ui: fix after merge

* python.pkgs.pytest-flake8: disable test, fix build

* Revert "meson: 0.46.1 -> 0.47.0"

With meson 0.47.0 (or 0.47.1, or git)
things are very wrong re:rpath handling
resulting in at best missing libs but
even corrupt binaries :(.

When we run patchelf it masks the problem
by removing obviously busted paths.
Which is probably why this wasn't noticed immediately.

Unfortunately the binary already
has a long series of paths scribbled
in a space intended for a much smaller string;
in my testing it was something like
lengths were 67 with 300+ written to it.

I think we've reported the relevant issues upstream,
but unfortunately it appears our patches
are what introduces the overwrite/corruption
(by no longer being correct in what they assume)

This doesn't look so bad to fix but it's
not something I can spend more time on
at the moment.

--

Interestingly the overwritten string data
(because it is scribbled past the bounds)
remains in the binary and is why we're suddenly
seeing unexpected references in various builds
-- notably this is is the reason we're
seeing the "extra-utils" breakage
that entirely crippled NixOS on master
(and probably on staging before?).

Fixes #43650.

This reverts commit 305ac4dade.

(cherry picked from commit 273d68eff8f7b6cd4ebed3718e5078a0f43cb55d)
Signed-off-by: Domen Kožar <domen@dev.si>
nixos-19.03
Frederik Rietdijk 4 years ago committed by Domen Kožar
parent
commit
099c13da1b
  1. 8
      pkgs/applications/editors/geany/default.nix
  2. 10
      pkgs/applications/graphics/dia/default.nix
  3. 5
      pkgs/applications/graphics/glabels/default.nix
  4. 10
      pkgs/applications/graphics/inkscape/default.nix
  5. 5
      pkgs/applications/networking/newsreaders/liferea/default.nix
  6. 9
      pkgs/applications/networking/p2p/transmission/default.nix
  7. 5
      pkgs/applications/office/gnucash/2.4.nix
  8. 6
      pkgs/applications/office/gnucash/2.6.nix
  9. 1
      pkgs/applications/version-management/git-and-tools/git/default.nix
  10. 9
      pkgs/applications/video/handbrake/default.nix
  11. 8
      pkgs/build-support/bintools-wrapper/setup-hook.sh
  12. 5
      pkgs/desktops/xfce/applications/orage.nix
  13. 5
      pkgs/desktops/xfce/applications/xfce4-notifyd.nix
  14. 5
      pkgs/desktops/xfce/core/thunar-build.nix
  15. 5
      pkgs/desktops/xfce/core/thunar-volman.nix
  16. 5
      pkgs/desktops/xfce/panel-plugins/xfce4-battery-plugin.nix
  17. 5
      pkgs/desktops/xfce/panel-plugins/xfce4-clipman-plugin.nix
  18. 6
      pkgs/desktops/xfce/panel-plugins/xfce4-cpufreq-plugin.nix
  19. 5
      pkgs/desktops/xfce/panel-plugins/xfce4-cpugraph-plugin.nix
  20. 5
      pkgs/desktops/xfce/panel-plugins/xfce4-netload-plugin.nix
  21. 6
      pkgs/desktops/xfce/panel-plugins/xfce4-pulseaudio-plugin.nix
  22. 6
      pkgs/desktops/xfce/panel-plugins/xfce4-weather-plugin.nix
  23. 5
      pkgs/desktops/xfce/thunar-plugins/archive/default.nix
  24. 6
      pkgs/desktops/xfce/thunar-plugins/dropbox/default.nix
  25. 2
      pkgs/development/interpreters/python/cpython/2.7/boot.nix
  26. 5
      pkgs/development/interpreters/ruby/default.nix
  27. 8
      pkgs/development/libraries/boost/1.67.nix
  28. 10
      pkgs/development/libraries/gvfs/default.nix
  29. 5
      pkgs/development/libraries/ilmbase/default.nix
  30. 1
      pkgs/development/libraries/libcommuni/default.nix
  31. 10
      pkgs/development/libraries/libffi/default.nix
  32. 6
      pkgs/development/libraries/librdf/rasqal.nix
  33. 4
      pkgs/development/libraries/mdds/default.nix
  34. 2
      pkgs/development/libraries/mesa/default.nix
  35. 11
      pkgs/development/libraries/mesa/missing-include.patch
  36. 55
      pkgs/development/libraries/mesa/missing-includes.patch
  37. 5
      pkgs/development/libraries/neon/0.29.nix
  38. 5
      pkgs/development/libraries/neon/default.nix
  39. 4
      pkgs/development/libraries/npth/default.nix
  40. 2
      pkgs/development/python-modules/hypothesis/default.nix
  41. 2
      pkgs/development/python-modules/pytest-flake8/default.nix
  42. 7
      pkgs/development/python-modules/pytest/default.nix
  43. 4
      pkgs/development/tools/build-managers/meson/default.nix
  44. 4
      pkgs/os-specific/linux/busybox/default.nix
  45. 4
      pkgs/os-specific/linux/util-linux/default.nix
  46. 4
      pkgs/servers/dns/bind/default.nix
  47. 36
      pkgs/stdenv/darwin/default.nix
  48. 4
      pkgs/stdenv/generic/setup.sh
  49. 6
      pkgs/tools/networking/curl/default.nix
  50. 14
      pkgs/tools/system/pciutils/default.nix
  51. 17
      pkgs/top-level/all-packages.nix
  52. 7
      pkgs/top-level/python-packages.nix

8
pkgs/applications/editors/geany/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, gtk2, which, pkgconfig, intltool, file, libintl }:
{ stdenv, fetchurl, gtk2, which, pkgconfig, intltool, file, libintl, hicolor-icon-theme }:
with stdenv.lib;
@ -15,7 +15,7 @@ stdenv.mkDerivation rec {
};
nativeBuildInputs = [ pkgconfig intltool libintl ];
buildInputs = [ gtk2 which file ];
buildInputs = [ gtk2 which file hicolor-icon-theme ];
doCheck = true;
@ -23,10 +23,6 @@ stdenv.mkDerivation rec {
patchPhase = "patchShebangs .";
# This file should normally require a gtk-update-icon-cache -q /usr/share/icons/hicolor command
# It have no reasons to exist in a redistribuable package
postInstall = "rm $out/share/icons/hicolor/icon-theme.cache";
meta = {
description = "Small and lightweight IDE";
longDescription = ''

10
pkgs/applications/graphics/dia/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchgit, autoconf, automake, libtool, gtk2, pkgconfig, perl,
perlXMLParser, libxml2, gettext, python, libxml2Python, docbook5, docbook_xsl,
libxslt, intltool, libart_lgpl, withGNOME ? false, libgnomeui,
libxslt, intltool, libart_lgpl, withGNOME ? false, libgnomeui, hicolor-icon-theme,
gtk-mac-integration }:
stdenv.mkDerivation rec {
@ -15,7 +15,7 @@ stdenv.mkDerivation rec {
buildInputs =
[ gtk2 perlXMLParser libxml2 gettext python libxml2Python docbook5
libxslt docbook_xsl libart_lgpl ]
libxslt docbook_xsl libart_lgpl hicolor-icon-theme ]
++ stdenv.lib.optional withGNOME libgnomeui
++ stdenv.lib.optional stdenv.isDarwin gtk-mac-integration;
@ -28,12 +28,6 @@ stdenv.mkDerivation rec {
hardeningDisable = [ "format" ];
# This file should normally require a gtk-update-icon-cache -q /usr/share/icons/hicolor command
# It have no reasons to exist in a redistribuable package
postInstall = ''
rm $out/share/icons/hicolor/icon-theme.cache
'';
meta = {
description = "Gnome Diagram drawing software";
homepage = http://live.gnome.org/Dia;

5
pkgs/applications/graphics/glabels/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, barcode, gnome3, autoreconfHook
, gtk3, gtk-doc, libxml2, librsvg , libtool, libe-book
, intltool, itstool, makeWrapper, pkgconfig
, intltool, itstool, makeWrapper, pkgconfig, hicolor-icon-theme
}:
stdenv.mkDerivation rec {
@ -17,11 +17,10 @@ stdenv.mkDerivation rec {
barcode gtk3 gtk-doc gnome3.yelp-tools
gnome3.gnome-common gnome3.gsettings-desktop-schemas
itstool libxml2 librsvg libe-book libtool
hicolor-icon-theme
];
preFixup = ''
rm "$out/share/icons/hicolor/icon-theme.cache"
wrapProgram "$out/bin/glabels-3" \
--prefix XDG_DATA_DIRS : "$GSETTINGS_SCHEMAS_PATH"
'';

10
pkgs/applications/graphics/inkscape/default.nix

@ -2,7 +2,7 @@
, libpng, zlib, popt, boehmgc, libxml2, libxslt, glib, gtkmm2
, glibmm, libsigcxx, lcms, boost, gettext, makeWrapper
, gsl, python2, poppler, imagemagick, libwpg, librevenge
, libvisio, libcdr, libexif, potrace, cmake
, libvisio, libcdr, libexif, potrace, cmake, hicolor-icon-theme
}:
let
@ -44,15 +44,13 @@ stdenv.mkDerivation rec {
libXft libpng zlib popt boehmgc
libxml2 libxslt glib gtkmm2 glibmm libsigcxx lcms boost gettext
gsl poppler imagemagick libwpg librevenge
libvisio libcdr libexif potrace
libvisio libcdr libexif potrace hicolor-icon-theme
];
enableParallelBuilding = true;
postInstall = ''
# Make sure PyXML modules can be found at run-time.
rm -f "$out/share/icons/hicolor/icon-theme.cache"
'' + stdenv.lib.optionalString stdenv.isDarwin ''
# Make sure PyXML modules can be found at run-time.
postInstall = stdenv.lib.optionalString stdenv.isDarwin ''
install_name_tool -change $out/lib/libinkscape_base.dylib $out/lib/inkscape/libinkscape_base.dylib $out/bin/inkscape
install_name_tool -change $out/lib/libinkscape_base.dylib $out/lib/inkscape/libinkscape_base.dylib $out/bin/inkview
'';

5
pkgs/applications/networking/newsreaders/liferea/default.nix

@ -1,7 +1,7 @@
{ stdenv, fetchurl, pkgconfig, intltool, python3Packages, wrapGAppsHook
, glib, libxml2, libxslt, sqlite, libsoup , webkitgtk, json-glib, gst_all_1
, libnotify, gtk3, gsettings-desktop-schemas, libpeas, dconf, librsvg
, gobjectIntrospection, glib-networking
, gobjectIntrospection, glib-networking, hicolor-icon-theme
}:
let
@ -20,7 +20,7 @@ in stdenv.mkDerivation rec {
buildInputs = [
glib gtk3 webkitgtk libxml2 libxslt sqlite libsoup gsettings-desktop-schemas
libpeas gsettings-desktop-schemas json-glib dconf gobjectIntrospection
librsvg glib-networking libnotify
librsvg glib-networking libnotify hicolor-icon-theme
] ++ (with gst_all_1; [
gstreamer gst-plugins-base gst-plugins-good gst-plugins-bad
]);
@ -28,7 +28,6 @@ in stdenv.mkDerivation rec {
pythonPath = with python3Packages; [ pygobject3 pycairo ];
preFixup = ''
rm "$out/share/icons/hicolor/icon-theme.cache"
buildPythonPath "$out $pythonPath"
gappsWrapperArgs+=(--prefix PYTHONPATH : "$program_PYTHONPATH")
'';

9
pkgs/applications/networking/p2p/transmission/default.nix

@ -1,5 +1,5 @@
{ stdenv, fetchurl, pkgconfig, intltool, file, wrapGAppsHook
, openssl, curl, libevent, inotify-tools, systemd, zlib
, openssl, curl, libevent, inotify-tools, systemd, zlib, hicolor-icon-theme
, enableGTK3 ? false, gtk3
, enableSystemd ? stdenv.isLinux
, enableDaemon ? true
@ -22,7 +22,8 @@ stdenv.mkDerivation rec {
buildInputs = [ intltool file openssl curl libevent zlib ]
++ optionals enableGTK3 [ gtk3 ]
++ optionals enableSystemd [ systemd ]
++ optionals stdenv.isLinux [ inotify-tools ];
++ optionals stdenv.isLinux [ inotify-tools ]
++ optionals enableGTK3 [ hicolor-icon-theme ];
postPatch = ''
substituteInPlace ./configure \
@ -39,10 +40,6 @@ stdenv.mkDerivation rec {
++ optional enableSystemd "--with-systemd-daemon"
++ optional enableGTK3 "--with-gtk";
preFixup = optionalString enableGTK3 ''
rm "$out/share/icons/hicolor/icon-theme.cache"
'';
NIX_LDFLAGS = optionalString stdenv.isDarwin "-framework CoreFoundation";
meta = with stdenv.lib; {

5
pkgs/applications/office/gnucash/2.4.nix

@ -1,7 +1,7 @@
{ fetchurl, stdenv, pkgconfig, libxml2, gconf, glib, gtk2, libgnomeui, libofx
, libgtkhtml, gtkhtml, libgnomeprint, goffice, enchant, gettext, libbonoboui
, intltool, perl, guile, slibGuile, swig, isocodes, bzip2, makeWrapper, libglade
, libgsf, libart_lgpl, perlPackages, aqbanking, gwenhywfar
, libgsf, libart_lgpl, perlPackages, aqbanking, gwenhywfar, hicolor-icon-theme
}:
/* If you experience GConf errors when running GnuCash on NixOS, see
@ -23,6 +23,7 @@ stdenv.mkDerivation rec {
libgnomeprint goffice enchant gettext intltool perl guile slibGuile
swig isocodes bzip2 makeWrapper libofx libglade libgsf libart_lgpl
perlPackages.DateManip perlPackages.FinanceQuote aqbanking gwenhywfar
hicolor-icon-theme
];
propagatedUserEnvPkgs = [ gconf ];
@ -49,8 +50,6 @@ stdenv.mkDerivation rec {
--set GCONF_CONFIG_SOURCE 'xml::~/.gconf' \
--prefix PATH ":" "$out/bin:${stdenv.lib.makeBinPath [ perl gconf ]}"
done
rm $out/share/icons/hicolor/icon-theme.cache
'';
# The following settings fix failures in the test suite. It's not required otherwise.

6
pkgs/applications/office/gnucash/2.6.nix

@ -3,7 +3,7 @@
, glib, gtk2, libofx, aqbanking, gwenhywfar, libgnomecanvas, goffice
, webkit, glibcLocales, gsettings-desktop-schemas, dconf
, gettext, swig, slibGuile, enchant, bzip2, isocodes, libdbi, libdbiDrivers
, pango, gdk_pixbuf
, pango, gdk_pixbuf, hicolor-icon-theme
}:
/*
@ -36,7 +36,7 @@ stdenv.mkDerivation rec {
libxml2 libxslt glibcLocales gettext swig enchant
bzip2 isocodes
# glib, gtk...
glib gtk2 goffice webkit
glib gtk2 goffice webkit hicolor-icon-theme
# gnome...
dconf gconf libgnomecanvas gsettings-desktop-schemas
# financial
@ -83,8 +83,6 @@ stdenv.mkDerivation rec {
--prefix GIO_EXTRA_MODULES : "${stdenv.lib.getLib dconf}/lib/gio/modules" \
--prefix PATH ":" "$out/bin:${stdenv.lib.makeBinPath [ perl gconf ]}"
done
rm $out/share/icons/hicolor/icon-theme.cache
'';
# The following settings fix failures in the test suite. It's not required otherwise.

1
pkgs/applications/version-management/git-and-tools/git/default.nix

@ -244,6 +244,7 @@ EOF
## InstallCheck
doCheck = false;
doInstallCheck = true;
installCheckTarget = "test";

9
pkgs/applications/video/handbrake/default.nix

@ -10,7 +10,7 @@
libogg, libopus, libtheora, libvorbis, libdvdcss, a52dec,
lame, libdvdread, libdvdnav, libbluray,
mp4v2, mpeg2dec, x264, x265, libmkv,
fontconfig, freetype,
fontconfig, freetype, hicolor-icon-theme,
glib, gtk3, intltool, libnotify,
gst_all_1, dbus-glib, udev, libgudev, libvpx,
useGtk ? true, wrapGAppsHook ? null, libappindicator-gtk3 ? null,
@ -50,7 +50,7 @@ stdenv.mkDerivation rec {
] ++ lib.optionals useGtk [
glib gtk3 libappindicator-gtk3 libnotify
gst_all_1.gstreamer gst_all_1.gst-plugins-base dbus-glib udev
libgudev
libgudev hicolor-icon-theme
] ++ (if useFfmpeg then [ ffmpeg ] else [ patched_libav_12 ])
++ lib.optional useFdk fdk_aac;
@ -82,11 +82,6 @@ stdenv.mkDerivation rec {
cd build
'';
# icon-theme.cache belongs in the icon theme, not in individual packages
postInstall = ''
rm $out/share/icons/hicolor/icon-theme.cache
'';
meta = with stdenv.lib; {
homepage = http://handbrake.fr/;
description = "A tool for converting video files and ripping DVDs";

8
pkgs/build-support/bintools-wrapper/setup-hook.sh

@ -20,7 +20,13 @@ bintoolsWrapper_addLDVars () {
fi
if [[ -d "$1/lib" ]]; then
export NIX_${role_pre}LDFLAGS+=" -L$1/lib"
# Don't add the /lib directory if it actually doesn't contain any libraries. For instance,
# Python and Haskell packages often only have directories like $out/lib/ghc-8.4.3/ or
# $out/lib/python3.6/, so having them in LDFLAGS just makes the linker search unnecessary
# directories and bloats the size of the environment variable space.
if [[ -n "$(echo $1/lib/lib*)" ]]; then
export NIX_${role_pre}LDFLAGS+=" -L$1/lib"
fi
fi
}

5
pkgs/desktops/xfce/applications/orage.nix

@ -1,6 +1,5 @@
{ stdenv, fetchurl, fetchpatch, pkgconfig, bison, flex, intltool, gtk, libical, dbus-glib, tzdata
, libnotify, popt, xfce
}:
, libnotify, popt, xfce, hicolor-icon-theme }:
stdenv.mkDerivation rec {
name = "${p_name}-${ver_maj}.${ver_min}";
@ -35,8 +34,6 @@ stdenv.mkDerivation rec {
buildInputs = [ gtk libical dbus-glib libnotify popt xfce.libxfce4util
xfce.xfce4-panel ];
preFixup = "rm $out/share/icons/hicolor/icon-theme.cache ";
meta = {
homepage = http://www.xfce.org/projects/;
description = "A simple calendar application with reminders";

5
pkgs/desktops/xfce/applications/xfce4-notifyd.nix

@ -1,5 +1,5 @@
{ stdenv, fetchurl, pkgconfig, intltool, libnotify
, gtk , libxfce4util, libxfce4ui, xfconf }:
, gtk , libxfce4util, libxfce4ui, xfconf, hicolor-icon-theme }:
stdenv.mkDerivation rec {
p_name = "xfce4-notifyd";
@ -13,10 +13,9 @@ stdenv.mkDerivation rec {
name = "${p_name}-${ver_maj}.${ver_min}";
nativeBuildInputs = [ pkgconfig ];
buildInputs = [ intltool libnotify gtk libxfce4util libxfce4ui xfconf ];
buildInputs = [ intltool libnotify gtk libxfce4util libxfce4ui xfconf hicolor-icon-theme ];
preFixup = ''
rm $out/share/icons/hicolor/icon-theme.cache
# to be able to run the daemon we need it in PATH
ln -rs $out/lib/xfce4/notifyd/xfce4-notifyd $out/bin
'';

5
pkgs/desktops/xfce/core/thunar-build.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, pkgconfig, intltool
, gtk, dbus-glib, libstartup_notification, libnotify, libexif, pcre, udev
, exo, libxfce4util, xfconf, xfce4-panel, wrapGAppsHook
, exo, libxfce4util, xfconf, xfce4-panel, hicolor-icon-theme, wrapGAppsHook
}:
stdenv.mkDerivation rec {
@ -26,13 +26,12 @@ stdenv.mkDerivation rec {
intltool
gtk dbus-glib libstartup_notification libnotify libexif pcre udev
exo libxfce4util xfconf xfce4-panel
hicolor-icon-theme
];
# TODO: optionality?
enableParallelBuilding = true;
preFixup = "rm $out/share/icons/hicolor/icon-theme.cache";
meta = {
homepage = http://thunar.xfce.org/;
description = "Xfce file manager";

5
pkgs/desktops/xfce/core/thunar-volman.nix

@ -1,5 +1,5 @@
{ stdenv, fetchurl, pkgconfig, intltool, exo, gtk, libxfce4util, libxfce4ui
, xfconf, udev, libgudev, libnotify }:
, xfconf, udev, libgudev, libnotify, hicolor-icon-theme }:
stdenv.mkDerivation rec {
p_name = "thunar-volman";
@ -15,9 +15,8 @@ stdenv.mkDerivation rec {
buildInputs =
[ pkgconfig intltool exo gtk udev libgudev libxfce4ui libxfce4util
xfconf libnotify
xfconf libnotify hicolor-icon-theme
];
preFixup = "rm $out/share/icons/hicolor/icon-theme.cache";
enableParallelBuilding = true;

5
pkgs/desktops/xfce/panel-plugins/xfce4-battery-plugin.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, pkgconfig, intltool, libxfce4util, xfce4-panel, libxfce4ui, libxfcegui4, xfconf, gtk}:
{ stdenv, fetchurl, pkgconfig, intltool, libxfce4util, xfce4-panel, libxfce4ui, libxfcegui4, xfconf, gtk, hicolor-icon-theme }:
with stdenv.lib;
stdenv.mkDerivation rec {
@ -13,8 +13,7 @@ stdenv.mkDerivation rec {
name = "${p_name}-${ver_maj}.${ver_min}";
nativeBuildInputs = [ pkgconfig ];
buildInputs = [ intltool libxfce4util libxfce4ui xfce4-panel libxfcegui4 xfconf gtk ];
preFixup = "rm $out/share/icons/hicolor/icon-theme.cache";
buildInputs = [ intltool libxfce4util libxfce4ui xfce4-panel libxfcegui4 xfconf gtk hicolor-icon-theme ];
meta = {
homepage = "http://goodies.xfce.org/projects/panel-plugins/${p_name}";

5
pkgs/desktops/xfce/panel-plugins/xfce4-clipman-plugin.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, pkgconfig, intltool, glib, exo, libXtst, xproto, libxfce4util, xfce4-panel, libxfce4ui, libxfcegui4, xfconf, gtk}:
{ stdenv, fetchurl, pkgconfig, intltool, glib, exo, libXtst, xproto, libxfce4util, xfce4-panel, libxfce4ui, libxfcegui4, xfconf, gtk, hicolor-icon-theme }:
with stdenv.lib;
stdenv.mkDerivation rec {
@ -13,8 +13,7 @@ stdenv.mkDerivation rec {
name = "${p_name}-${ver_maj}.${ver_min}";
nativeBuildInputs = [ pkgconfig ];
buildInputs = [ intltool glib exo libXtst xproto libxfce4util libxfce4ui xfce4-panel libxfcegui4 xfconf gtk ];
preFixup = "rm $out/share/icons/hicolor/icon-theme.cache";
buildInputs = [ intltool glib exo libXtst xproto libxfce4util libxfce4ui xfce4-panel libxfcegui4 xfconf gtk hicolor-icon-theme ];
meta = {
homepage = "http://goodies.xfce.org/projects/panel-plugins/${p_name}";

6
pkgs/desktops/xfce/panel-plugins/xfce4-cpufreq-plugin.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, pkgconfig, intltool, libxfce4util, xfce4-panel, libxfce4ui, libxfcegui4, xfconf, gtk}:
{ stdenv, fetchurl, pkgconfig, intltool, libxfce4util, xfce4-panel, libxfce4ui, libxfcegui4, xfconf, gtk, hicolor-icon-theme }:
with stdenv.lib;
stdenv.mkDerivation rec {
@ -15,12 +15,10 @@ stdenv.mkDerivation rec {
nativeBuildInputs = [ pkgconfig intltool ];
buildInputs = [ libxfce4util libxfce4ui xfce4-panel libxfcegui4 xfconf gtk ];
buildInputs = [ libxfce4util libxfce4ui xfce4-panel libxfcegui4 xfconf gtk hicolor-icon-theme ];
enableParallelBuilding = true;
preFixup = "rm $out/share/icons/hicolor/icon-theme.cache";
meta = {
homepage = "http://goodies.xfce.org/projects/panel-plugins/${p_name}";
description = "CPU Freq load plugin for Xfce panel";

5
pkgs/desktops/xfce/panel-plugins/xfce4-cpugraph-plugin.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, pkgconfig, intltool, glib, exo, libXtst, xproto, libxfce4util, xfce4-panel, libxfce4ui, xfconf, gtk}:
{ stdenv, fetchurl, pkgconfig, intltool, glib, exo, libXtst, xproto, libxfce4util, xfce4-panel, libxfce4ui, xfconf, gtk, hicolor-icon-theme }:
with stdenv.lib;
stdenv.mkDerivation rec {
@ -13,8 +13,7 @@ stdenv.mkDerivation rec {
name = "${p_name}-${ver_maj}.${ver_min}";
nativeBuildInputs = [ pkgconfig ];
buildInputs = [ intltool glib exo libXtst xproto libxfce4util libxfce4ui xfce4-panel xfconf gtk ];
preFixup = "rm $out/share/icons/hicolor/icon-theme.cache";
buildInputs = [ intltool glib exo libXtst xproto libxfce4util libxfce4ui xfce4-panel xfconf gtk hicolor-icon-theme ];
meta = {
homepage = "http://goodies.xfce.org/projects/panel-plugins/${p_name}";

5
pkgs/desktops/xfce/panel-plugins/xfce4-netload-plugin.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, pkgconfig, intltool, libxfce4util, xfce4-panel, libxfce4ui, libxfcegui4, xfconf, gtk}:
{ stdenv, fetchurl, pkgconfig, intltool, libxfce4util, xfce4-panel, libxfce4ui, libxfcegui4, xfconf, gtk, hicolor-icon-theme }:
with stdenv.lib;
stdenv.mkDerivation rec {
@ -13,8 +13,7 @@ stdenv.mkDerivation rec {
name = "${p_name}-${ver_maj}.${ver_min}";
nativeBuildInputs = [ pkgconfig ];
buildInputs = [ intltool libxfce4util libxfce4ui xfce4-panel libxfcegui4 xfconf gtk ];
preFixup = "rm $out/share/icons/hicolor/icon-theme.cache";
buildInputs = [ intltool libxfce4util libxfce4ui xfce4-panel libxfcegui4 xfconf gtk hicolor-icon-theme ];
meta = {
homepage = "http://goodies.xfce.org/projects/panel-plugins/${p_name}";

6
pkgs/desktops/xfce/panel-plugins/xfce4-pulseaudio-plugin.nix

@ -1,5 +1,5 @@
{ stdenv, fetchurl, pkgconfig, intltool, libxfce4util, xfce4panel_gtk3, xfconf
, gtk3, libpulseaudio
, gtk3, libpulseaudio, hicolor-icon-theme
, withKeybinder ? true, keybinder3
, withLibnotify ? true, libnotify
}:
@ -21,12 +21,10 @@ stdenv.mkDerivation rec {
name = "${p_name}-${ver_maj}.${ver_min}";
nativeBuildInputs = [ pkgconfig intltool ];
buildInputs = [ libxfce4util xfce4panel_gtk3 xfconf gtk3 libpulseaudio ]
buildInputs = [ libxfce4util xfce4panel_gtk3 xfconf gtk3 libpulseaudio hicolor-icon-theme ]
++ optional withKeybinder keybinder3
++ optional withLibnotify libnotify;
preFixup = "rm $out/share/icons/hicolor/icon-theme.cache";
meta = {
homepage = "http://goodies.xfce.org/projects/panel-plugins/${p_name}";
description = "Adjust the audio volume of the PulseAudio sound system";

6
pkgs/desktops/xfce/panel-plugins/xfce4-weather-plugin.nix

@ -1,5 +1,5 @@
{ stdenv, fetchurl, pkgconfig, intltool, gtk, libxml2, libsoup, upower,
libxfce4ui, libxfce4util, xfce4-panel }:
libxfce4ui, libxfce4util, xfce4-panel, hicolor-icon-theme }:
stdenv.mkDerivation rec {
name = "${p_name}-${ver_maj}.${ver_min}";
@ -15,12 +15,10 @@ stdenv.mkDerivation rec {
nativeBuildInputs = [ pkgconfig intltool ];
buildInputs = [ gtk libxml2 libsoup upower libxfce4ui libxfce4util
xfce4-panel ];
xfce4-panel hicolor-icon-theme ];
enableParallelBuilding = true;
preFixup = "rm $out/share/icons/hicolor/icon-theme.cache";
meta = {
homepage = "http://goodies.xfce.org/projects/panel-plugins/${p_name}";
description = "Weather plugin for the Xfce desktop environment";

5
pkgs/desktops/xfce/thunar-plugins/archive/default.nix

@ -2,7 +2,7 @@
, gtk
, thunar-bare
, exo, libxfce4util, libxfce4ui
, xfconf, udev, libnotify
, xfconf, udev, libnotify, hicolor-icon-theme
}:
stdenv.mkDerivation rec {
@ -23,7 +23,7 @@ stdenv.mkDerivation rec {
xfce4-dev-tools
thunar-bare
exo gtk libxfce4util libxfce4ui
xfconf udev libnotify
xfconf udev libnotify hicolor-icon-theme
];
preConfigure = ''
@ -44,7 +44,6 @@ stdenv.mkDerivation rec {
pushd $out/libexec/thunar-archive-plugin > /dev/null
ln -s ./file-roller.tap org.gnome.FileRoller.tap
popd > /dev/null
rm $out/share/icons/hicolor/icon-theme.cache
'';
enableParallelBuilding = true;

6
pkgs/desktops/xfce/thunar-plugins/dropbox/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, pkgconfig
, gtk
, thunar-bare, python2
, thunar-bare, python2, hicolor-icon-theme
}:
stdenv.mkDerivation rec {
@ -17,7 +17,7 @@ stdenv.mkDerivation rec {
nativeBuildInputs = [ pkgconfig ];
buildInputs = [
gtk
thunar-bare python2
thunar-bare python2 hicolor-icon-theme
];
configurePhase = "python2 waf configure --prefix=$out";
@ -28,8 +28,6 @@ stdenv.mkDerivation rec {
python2 waf install
'';
preFixup = "rm $out/share/icons/hicolor/icon-theme.cache";
enableParallelBuilding = true;
meta = with stdenv.lib; {

2
pkgs/development/interpreters/python/cpython/2.7/boot.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, CF, configd, coreutils }:
{ stdenv, fetchurl, configd, CF, coreutils }:
with stdenv.lib;

5
pkgs/development/interpreters/ruby/default.nix

@ -133,6 +133,11 @@ let
++ op (stdenv.hostPlatform != stdenv.buildPlatform)
"--with-baseruby=${buildRuby}";
# fails with "16993 tests, 2229489 assertions, 105 failures, 14 errors, 89 skips"
# mostly TZ- and patch-related tests
# TZ- failures are caused by nix sandboxing, I didn't investigate others
doCheck = false;
preInstall = ''
# Ruby installs gems here itself now.
mkdir -pv "$out/${passthru.gemPath}"

8
pkgs/development/libraries/boost/1.67.nix

@ -1,8 +1,14 @@
{ stdenv, callPackage, fetchurl, hostPlatform, buildPlatform, ... } @ args:
{ stdenv, callPackage, fetchurl, fetchpatch, hostPlatform, buildPlatform, ... } @ args:
callPackage ./generic.nix (args // rec {
version = "1.67_0";
patches = [ (fetchpatch {
url = "https://github.com/boostorg/lockfree/commit/12726cda009a855073b9bedbdce57b6ce7763da2.patch";
sha256 = "0x65nkwzv8fdacj8sw5njl3v63jj19dirrpklbwy6qpsncw7fc7h";
stripLen = 1;
})];
src = fetchurl {
url = "mirror://sourceforge/boost/boost_1_67_0.tar.bz2";
# SHA256 from http://www.boost.org/users/history/version_1_66_0.html

10
pkgs/development/libraries/gvfs/default.nix

@ -4,7 +4,7 @@
, libxml2, libxslt, docbook_xsl, docbook_xml_dtd_42, samba, libmtp
, gnomeSupport ? false, gnome, makeWrapper
, libimobiledevice, libbluray, libcdio-paranoia, libnfs, openssh
, libsecret, libgdata
, libsecret, libgdata, python3
# Remove when switching back to meson
, autoreconfHook, lzma, bzip2
}:
@ -28,6 +28,10 @@ stdenv.mkDerivation rec {
sha256 = "1xq105596sk9yram5a143b369wpaiiwc9gz86n0j1kfr7nipkqn4";
};
postPatch = ''
patchShebangs test test-driver
'';
# Uncomment when switching back to meson
# postPatch = ''
# chmod +x meson_post_install.py # patchShebangs requires executable file
@ -73,6 +77,10 @@ stdenv.mkDerivation rec {
enableParallelBuilding = true;
checkInputs = [ python3 ];
doCheck = false; # fails with "ModuleNotFoundError: No module named 'gi'"
doInstallCheck = doCheck;
preFixup = ''
for f in $out/libexec/*; do
wrapProgram $f \

5
pkgs/development/libraries/ilmbase/default.nix

@ -20,6 +20,11 @@ stdenv.mkDerivation rec {
patches = [ ./bootstrap.patch ];
# fails 1 out of 1 tests with
# "lt-ImathTest: testBoxAlgo.cpp:892: void {anonymous}::boxMatrixTransform(): Assertion `b21 == b2' failed"
# at least on i686. spooky!
doCheck = stdenv.isx86_64;
meta = with stdenv.lib; {
homepage = http://www.openexr.com/;
license = licenses.bsd3;

1
pkgs/development/libraries/libcommuni/default.nix

@ -27,6 +27,7 @@ stdenv.mkDerivation rec {
# The tests fail on darwin because of install_name if they run
# before the frameworks are installed.
doCheck = false;
doInstallCheck = true;
installCheckTarget = "check";

10
pkgs/development/libraries/libffi/default.nix

@ -1,5 +1,9 @@
{ stdenv, fetchurl, fetchpatch, dejagnu, doCheck ? false
{ stdenv, fetchurl, fetchpatch
, buildPlatform, hostPlatform, autoreconfHook
# libffi is used in darwin stdenv
# we cannot run checks within it
, doCheck ? !stdenv.isDarwin, dejagnu
}:
stdenv.mkDerivation rec {
@ -40,8 +44,6 @@ stdenv.mkDerivation rec {
outputs = [ "out" "dev" "man" "info" ];
buildInputs = stdenv.lib.optional doCheck dejagnu;
nativeBuildInputs = stdenv.lib.optional hostPlatform.isRiscV autoreconfHook;
configureFlags = [
@ -54,6 +56,8 @@ stdenv.mkDerivation rec {
NIX_HARDENING_ENABLE=''${NIX_HARDENING_ENABLE/fortify/}
'';
checkInputs = [ dejagnu ];
inherit doCheck;
dontStrip = hostPlatform != buildPlatform; # Don't run the native `strip' when cross-compiling.

6
pkgs/development/libraries/librdf/rasqal.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, librdf_raptor2, gmp, pkgconfig, pcre, libxml2 }:
{ stdenv, fetchurl, librdf_raptor2, gmp, pkgconfig, pcre, libxml2, perl }:
stdenv.mkDerivation rec {
name = "rasqal-0.9.33";
@ -16,6 +16,10 @@ stdenv.mkDerivation rec {
postInstall = "rm -rvf $out/share/gtk-doc";
checkInputs = [ perl ];
doCheck = false; # fails with "No testsuite plan file sparql-query-plan.ttl could be created in build/..."
doInstallCheck = false; # fails with "rasqal-config does not support (--help|--version)"
meta = {
description = "Library that handles Resource Description Framework (RDF)";
homepage = http://librdf.org/rasqal;

4
pkgs/development/libraries/mdds/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl }:
{ stdenv, fetchurl, boost }:
stdenv.mkDerivation rec {
version = "1.3.1";
@ -14,6 +14,8 @@ stdenv.mkDerivation rec {
cp "$out/share/pkgconfig/"* "$out/lib/pkgconfig"
'';
checkInputs = [ boost ];
meta = {
inherit version;
homepage = https://gitlab.com/mdds/mdds;

2
pkgs/development/libraries/mesa/default.nix

@ -92,7 +92,7 @@ let self = stdenv.mkDerivation {
patches = [
./glx_ro_text_segm.patch # fix for grsecurity/PaX
./symlink-drivers.patch
./missing-include.patch # dev_t needs sys/stat.h, fixes build w/musl
./missing-includes.patch # dev_t needs sys/stat.h, time_t needs time.h, etc.-- fixes build w/musl
];
outputs = [ "out" "dev" "drivers" "osmesa" ];

11
pkgs/development/libraries/mesa/missing-include.patch

@ -1,11 +0,0 @@
--- ./src/gallium/winsys/svga/drm/vmw_screen.h.orig
+++ ./src/gallium/winsys/svga/drm/vmw_screen.h
@@ -34,7 +34,7 @@
#ifndef VMW_SCREEN_H_
#define VMW_SCREEN_H_
-
+#include <sys/stat.h>
#include "pipe/p_compiler.h"
#include "pipe/p_state.h"

55
pkgs/development/libraries/mesa/missing-includes.patch

@ -0,0 +1,55 @@
--- ./src/gallium/winsys/svga/drm/vmw_screen.h.orig
+++ ./src/gallium/winsys/svga/drm/vmw_screen.h
@@ -34,7 +34,7 @@
#ifndef VMW_SCREEN_H_
#define VMW_SCREEN_H_
-
+#include <sys/stat.h>
#include "pipe/p_compiler.h"
#include "pipe/p_state.h"
--- ./src/gallium/state_trackers/nine/threadpool.h.orig 2015-05-07 14:10:53.443337212 +0200
+++ ./src/gallium/state_trackers/nine/threadpool.h 2015-05-07 14:11:04.210307653 +0200
@@ -24,6 +24,8 @@
#ifndef _THREADPOOL_H_
#define _THREADPOOL_H_
+#include <pthread.h>
+
#define MAXTHREADS 1
struct threadpool {
--- ./src/util/rand_xor.c.orig 2017-06-20 00:38:57.199474067 +0200
+++ ./src/util/rand_xor.c 2017-06-20 00:40:31.351279557 +0200
@@ -23,7 +23,9 @@
*/
#if defined(__linux__)
+#include <sys/types.h>
#include <sys/file.h>
+#include <sys/stat.h>
#include <unistd.h>
#include <fcntl.h>
#else
--- ./src/mesa/drivers/dri/i965/brw_bufmgr.h
+++ ./src/mesa/drivers/dri/i965/brw_bufmgr.h
@@ -37,6 +37,7 @@
#include <stdbool.h>
#include <stdint.h>
#include <stdio.h>
+#include <time.h>
#include "util/u_atomic.h"
#include "util/list.h"
--- ./src/amd/vulkan/winsys/amdgpu/radv_amdgpu_winsys.h
+++ ./src/amd/vulkan/winsys/amdgpu/radv_amdgpu_winsys.h
@@ -28,6 +28,8 @@
#ifndef RADV_AMDGPU_WINSYS_H
#define RADV_AMDGPU_WINSYS_H
+#include <sys/types.h>
+
#include "radv_radeon_winsys.h"
#include "ac_gpu_info.h"
#include "addrlib/addrinterface.h"<Paste>

5
pkgs/development/libraries/neon/0.29.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, libxml2, pkgconfig
{ stdenv, fetchurl, libxml2, pkgconfig, perl
, compressionSupport ? true, zlib ? null
, sslSupport ? true, openssl ? null
, static ? false
@ -38,6 +38,9 @@ stdenv.mkDerivation rec {
passthru = {inherit compressionSupport sslSupport;};
checkInputs = [ perl ];
doCheck = false; # fails, needs the net
meta = {
description = "An HTTP and WebDAV client library";
homepage = http://www.webdav.org/neon/;

5
pkgs/development/libraries/neon/default.nix

@ -1,4 +1,4 @@
{ stdenv, fetchurl, libxml2, pkgconfig
{ stdenv, fetchurl, libxml2, pkgconfig, perl
, compressionSupport ? true, zlib ? null
, sslSupport ? true, openssl ? null
, static ? false
@ -38,6 +38,9 @@ stdenv.mkDerivation rec {
passthru = {inherit compressionSupport sslSupport;};
checkInputs = [ perl ];
doCheck = false; # fails, needs the net
meta = {
description = "An HTTP and WebDAV client library";
homepage = http://www.webdav.org/neon/;

4
pkgs/development/libraries/npth/default.nix

@ -1,11 +1,11 @@
{ stdenv, fetchurl }:
stdenv.mkDerivation rec {
name = "npth-1.5";
name = "npth-1.6";
src = fetchurl {
url = "mirror://gnupg/npth/${name}.tar.bz2";
sha256 = "1hmkkp6vzyrh8v01c2ynzf9vwikyagp7p1lxhbnr4ysk3w66jji9";
sha256 = "1lg2lkdd3z1s3rpyf88786l243adrzyk9p4q8z9n41ygmpcsp4qk";
};
doCheck = true;

2
pkgs/development/python-modules/hypothesis/default.nix

@ -20,9 +20,9 @@ buildPythonPackage rec {
sha256 = "063sn5m1966gvm3wrlxczdq4vw0r94h3nd9xpr94qxahpg2r4bpb";
};
checkInputs = [ pytest pytest_xdist flaky mock ];
propagatedBuildInputs = [ attrs coverage ] ++ lib.optional (!isPy3k) [ enum34 ];
checkInputs = [ pytest pytest_xdist flaky mock ];
inherit doCheck;
# https://github.com/DRMacIver/hypothesis/issues/300

2
pkgs/development/python-modules/pytest-flake8/default.nix

@ -16,7 +16,7 @@ buildPythonPackage rec {
};
checkPhase = ''
pytest .
pytest . -k "not test_mtime_caching"
'';
meta = {

7
pkgs/development/python-modules/pytest/default.nix

@ -1,6 +1,6 @@
{ stdenv, buildPythonPackage, fetchPypi, attrs, hypothesis, py
, setuptools_scm, setuptools, six, pluggy, funcsigs, isPy3k, more-itertools
, atomicwrites, mock
, atomicwrites, mock, writeText
}:
buildPythonPackage rec {
version = "3.6.2";
@ -27,6 +27,11 @@ buildPythonPackage rec {
runHook postCheck
'';
# Don't create .pytest-cache when using py.test in a Nix build
setupHook = writeText "pytest-hook" ''
export PYTEST_ADDOPTS="-p no:cacheprovider"
'';
meta = with stdenv.lib; {
maintainers = with maintainers; [ domenkozar lovek323 madjar lsix ];
platforms = platforms.unix;

4
pkgs/development/tools/build-managers/meson/default.nix

@ -2,12 +2,12 @@
targetPrefix = lib.optionalString stdenv.isCross
(targetPlatform.config + "-");
in python3Packages.buildPythonApplication rec {
version = "0.47.0";
version = "0.46.1";
pname = "meson";
src = python3Packages.fetchPypi {
inherit pname version;
sha256 = "1mxsvsw7mg3q4yj8qrkrwv79qwws14qnbihryn2i7504b3r204h6";
sha256 = "1jdxs2mkniy1hpdjc4b4jb95axsjp6j5fzphmm6d4gqmqyykjvqc";
};
postFixup = ''

4
pkgs/os-specific/linux/busybox/default.nix

@ -32,14 +32,14 @@ let
in
stdenv.mkDerivation rec {
name = "busybox-1.29.0";
name = "busybox-1.29.1";
# Note to whoever is updating busybox: please verify that:
# nix-build pkgs/stdenv/linux/make-bootstrap-tools.nix -A test
# still builds after the update.
src = fetchurl {
url = "https://busybox.net/downloads/${name}.tar.bz2";
sha256 = "10hccqprhr1mwkqc9i3kny44mb6sdmv9hl63wx20cr5yy095c4f8";
sha256 = "1hqlr5b3bsyb6avadz1z4za6pyl32r1krnpcpwwqilhnx8q0f9gw";
};
hardeningDisable = [ "format" ] ++ lib.optionals enableStatic [ "fortify" ];

4
pkgs/os-specific/linux/util-linux/default.nix

@ -5,14 +5,14 @@ let
version = lib.concatStringsSep "." ([ majorVersion ]
++ lib.optional (patchVersion != "") patchVersion);
majorVersion = "2.32";
patchVersion = "";
patchVersion = "1";
in stdenv.mkDerivation rec {
name = "util-linux-${version}";
src = fetchurl {
url = "mirror://kernel/linux/utils/util-linux/v${majorVersion}/${name}.tar.xz";
sha256 = "0d2758kjll5xqm5fpp3sww1h66aahx161sf2b60jxqv4qymrfwvc";
sha256 = "1ck7d8srw5szpjq7v0gpmjahnjs6wgqzm311ki4gazww6xx71rl6";
};
patches = [

4
pkgs/servers/dns/bind/default.nix

@ -8,14 +8,14 @@
assert enableSeccomp -> libseccomp != null;
assert enablePython -> python3 != null;
let version = "9.12.1-P2"; in
let version = "9.12.2"; in
stdenv.mkDerivation rec {
name = "bind-${version}";
src = fetchurl {
url = "https://ftp.isc.org/isc/bind9/${version}/${name}.tar.gz";
sha256 = "0a9dvyg1dk7vpqn9gz7p5jas3bz7z22bjd66b98g1qk16i2w7rqd";
sha256 = "0ll46igs9xfq2qclc5wzqsnj3zv7ssga0544gm24s1m7765lqslz";
};
outputs = [ "out" "lib" "dev" "man" "dnsutils" "host" ];

36
pkgs/stdenv/darwin/default.nix vendored

@ -188,7 +188,18 @@ in rec {
};
stage1 = prevStage: let
persistent = _: super: { python = super.python.override { configd = null; }; };
persistent = self: super: with prevStage; {
cmake = super.cmake.override {
majorVersion = "3.9"; # FIXME: update ApplicationServices patch
isBootstrap = true;
useSharedLibraries = false;
};
python = super.callPackage ../../development/interpreters/python/cpython/2.7/boot.nix {
CF = null; # use CoreFoundation from bootstrap-tools
configd = null;
};
};
in with prevStage; stageFun 1 prevStage {
extraPreHook = "export NIX_CFLAGS_COMPILE+=\" -F${bootstrapTools}/Library/Frameworks\"";
extraNativeBuildInputs = [];
@ -239,6 +250,9 @@ in rec {
openssh sqlite sed serf openldap db cyrus-sasl expat apr-util
findfreetype libssh curl cmake autoconf automake libtool cpio;
# Avoid pulling in a full python and it's extra dependencies for the llvm/clang builds.
libxml2 = super.libxml2.override { pythonSupport = false; };
llvmPackages_5 = super.llvmPackages_5 // (let
libraries = super.llvmPackages_5.libraries.extend (_: _: {
inherit (llvmPackages_5) libcxx libcxxabi;
@ -281,6 +295,15 @@ in rec {
ncurses libffi zlib gmp pcre gnugrep
coreutils findutils diffutils patchutils;
# Hack to make sure we don't link ncurses in bootstrap tools. The proper
# solution is to avoid passing -L/nix-store/...-bootstrap-tools/lib,
# quite a sledgehammer just to get the C runtime.
gettext = super.gettext.overrideAttrs (drv: {
configureFlags = drv.configureFlags ++ [
"--disable-curses"
];
});
llvmPackages_5 = super.llvmPackages_5 // (let
tools = super.llvmPackages_5.tools.extend (llvmSelf: _: {
inherit (llvmPackages_5) llvm clang-unwrapped;
@ -303,16 +326,7 @@ in rec {
extraPreHook = ''
export PATH_LOCALE=${pkgs.darwin.locale}/share/locale
'';
overrides = lib.composeExtensions persistent (self: super: {
# Hack to make sure we don't link ncurses in bootstrap tools. The proper
# solution is to avoid passing -L/nix-store/...-bootstrap-tools/lib,
# quite a sledgehammer just to get the C runtime.
gettext = super.gettext.overrideAttrs (old: {
configureFlags = old.configureFlags ++ [
"--disable-curses"
];
});
});
overrides = persistent;
};
stdenvDarwin = prevStage: let

4
pkgs/stdenv/generic/setup.sh vendored

@ -660,6 +660,10 @@ substituteStream() {
echo "substituteStream(): ERROR: substitution variables must be valid Bash names, \"$varName\" isn't." >&2
return 1
fi
if [ -z ${!varName+x} ]; then
echo "substituteStream(): ERROR: variable \$$varName is unset" >&2
return 1
fi
pattern="@$varName@"
replacement="${!varName}"
;;