Browse Source

treewide: remove redundant rec

alephone
volth 2 years ago
parent
commit
08f68313a4
  1. 2
      lib/deprecated.nix
  2. 2
      lib/kernel.nix
  3. 2
      lib/licenses.nix
  4. 2
      lib/systems/doubles.nix
  5. 18
      lib/systems/examples.nix
  6. 2
      lib/systems/parse.nix
  7. 6
      lib/types.nix
  8. 2
      lib/versions.nix
  9. 2
      nixos/lib/make-options-doc/default.nix
  10. 2
      nixos/lib/utils.nix
  11. 2
      nixos/modules/config/malloc.nix
  12. 2
      nixos/modules/installer/cd-dvd/system-tarball-pc.nix
  13. 2
      nixos/modules/installer/netboot/netboot.nix
  14. 2
      nixos/modules/programs/firejail.nix
  15. 2
      nixos/modules/services/cluster/kubernetes/default.nix
  16. 2
      nixos/modules/services/continuous-integration/hydra/default.nix
  17. 2
      nixos/modules/services/hardware/sane_extra_backends/brscan4_etc_files.nix
  18. 4
      nixos/modules/services/misc/gitlab.nix
  19. 2
      nixos/modules/services/misc/pykms.nix
  20. 2
      nixos/modules/services/misc/zoneminder.nix
  21. 2
      nixos/modules/services/network-filesystems/openafs/lib.nix
  22. 2
      nixos/modules/services/networking/kippo.nix
  23. 2
      nixos/modules/services/web-apps/frab.nix
  24. 2
      nixos/modules/services/web-apps/wordpress.nix
  25. 2
      nixos/tests/borgbackup.nix
  26. 2
      nixos/tests/ceph.nix
  27. 3
      nixos/tests/cjdns.nix
  28. 2
      nixos/tests/cockroachdb.nix
  29. 2
      nixos/tests/containers-reloadable.nix
  30. 2
      nixos/tests/containers-restart_networking.nix
  31. 2
      nixos/tests/flannel.nix
  32. 2
      nixos/tests/hardened.nix
  33. 2
      nixos/tests/initrd-network-ssh/default.nix
  34. 2
      nixos/tests/jackett.nix
  35. 2
      nixos/tests/lidarr.nix
  36. 2
      nixos/tests/mosquitto.nix
  37. 2
      nixos/tests/quake3.nix
  38. 2
      nixos/tests/radarr.nix
  39. 2
      nixos/tests/sonarr.nix
  40. 2
      pkgs/applications/altcoins/parity/parity.nix
  41. 2
      pkgs/applications/audio/a2jmidid/default.nix
  42. 2
      pkgs/applications/audio/cantata/default.nix
  43. 2
      pkgs/applications/audio/caudec/default.nix
  44. 2
      pkgs/applications/audio/cmusfm/default.nix
  45. 2
      pkgs/applications/audio/csound/csound-manual/default.nix
  46. 2
      pkgs/applications/audio/deadbeef/plugins/lyricbar.nix
  47. 2
      pkgs/applications/audio/dirt/default.nix
  48. 2
      pkgs/applications/audio/faust/faustlive.nix
  49. 2
      pkgs/applications/audio/fluidsynth/default.nix
  50. 2
      pkgs/applications/audio/fmsynth/default.nix
  51. 2
      pkgs/applications/audio/foo-yc20/default.nix
  52. 2
      pkgs/applications/audio/gnome-podcasts/default.nix
  53. 2
      pkgs/applications/audio/gradio/default.nix
  54. 2
      pkgs/applications/audio/helm/default.nix
  55. 2
      pkgs/applications/audio/iannix/default.nix
  56. 2
      pkgs/applications/audio/jackmix/default.nix
  57. 2
      pkgs/applications/audio/lv2bm/default.nix
  58. 2
      pkgs/applications/audio/mod-distortion/default.nix
  59. 2
      pkgs/applications/audio/muse/default.nix
  60. 2
      pkgs/applications/audio/musly/default.nix
  61. 2
      pkgs/applications/audio/non/default.nix
  62. 2
      pkgs/applications/audio/nova-filters/default.nix
  63. 2
      pkgs/applications/audio/openmpt123/default.nix
  64. 2
      pkgs/applications/audio/patchage/default.nix
  65. 2
      pkgs/applications/audio/pd-plugins/helmholtz/default.nix
  66. 2
      pkgs/applications/audio/pd-plugins/mrpeach/default.nix
  67. 2
      pkgs/applications/audio/pianobooster/default.nix
  68. 2
      pkgs/applications/audio/plugin-torture/default.nix
  69. 2
      pkgs/applications/audio/pulseaudio-dlna/default.nix
  70. 2
      pkgs/applications/audio/rhvoice/default.nix
  71. 2
      pkgs/applications/audio/shntool/default.nix
  72. 2
      pkgs/applications/audio/soundscape-renderer/default.nix
  73. 4
      pkgs/applications/audio/speech-denoiser/default.nix
  74. 2
      pkgs/applications/audio/spotifywm/default.nix
  75. 2
      pkgs/applications/audio/svox/default.nix
  76. 2
      pkgs/applications/audio/traverso/default.nix
  77. 2
      pkgs/applications/audio/uade123/default.nix
  78. 2
      pkgs/applications/audio/zam-plugins/default.nix
  79. 2
      pkgs/applications/backup/areca/default.nix
  80. 2
      pkgs/applications/display-managers/lightdm-enso-os-greeter/default.nix
  81. 2
      pkgs/applications/display-managers/sddm/default.nix
  82. 2
      pkgs/applications/editors/android-studio/default.nix
  83. 2
      pkgs/applications/editors/aseprite/skia.nix
  84. 2
      pkgs/applications/editors/edit/default.nix
  85. 2
      pkgs/applications/editors/elvis/default.nix
  86. 2
      pkgs/applications/editors/emacs-modes/cedille/default.nix
  87. 2
      pkgs/applications/editors/emacs-modes/coffee/default.nix
  88. 2
      pkgs/applications/editors/emacs-modes/color-theme-solarized/default.nix
  89. 2
      pkgs/applications/editors/emacs-modes/emacs-w3m/default.nix
  90. 2
      pkgs/applications/editors/emacs-modes/flymake-cursor/default.nix
  91. 2
      pkgs/applications/editors/emacs-modes/gh/default.nix
  92. 2
      pkgs/applications/editors/emacs-modes/gist/default.nix
  93. 2
      pkgs/applications/editors/emacs-modes/logito/default.nix
  94. 2
      pkgs/applications/editors/emacs-modes/lorem-ipsum/default.nix
  95. 6
      pkgs/applications/editors/emacs-modes/manual-packages.nix
  96. 2
      pkgs/applications/editors/emacs-modes/melpa-packages.nix
  97. 2
      pkgs/applications/editors/emacs-modes/metaweblog/default.nix
  98. 2
      pkgs/applications/editors/emacs-modes/org-mac-link/default.nix
  99. 2
      pkgs/applications/editors/emacs-modes/org2blog/default.nix
  100. 2
      pkgs/applications/editors/emacs-modes/pcache/default.nix

2
lib/deprecated.nix

@ -24,7 +24,7 @@ rec {
let arg = (merger init (defaultMergeArg init x));
# now add the function with composed args already applied to the final attrs
base = (setAttrMerge "passthru" {} (f arg)
( z: z // rec {
( z: z // {
function = foldArgs merger f arg;
args = (lib.attrByPath ["passthru" "args"] {} z) // x;
} ));

2
lib/kernel.nix

@ -1,7 +1,7 @@
{ lib, version }:
with lib;
rec {
{
# Common patterns/legacy
whenAtLeast = ver: mkIf (versionAtLeast version ver);
whenOlder = ver: mkIf (versionOlder version ver);

2
lib/licenses.nix

@ -7,7 +7,7 @@ let
in
lib.mapAttrs (n: v: v // { shortName = n; }) rec {
lib.mapAttrs (n: v: v // { shortName = n; }) {
/* License identifiers from spdx.org where possible.
* If you cannot find your license here, then look for a similar license or
* add it to this list. The URL mentioned above is a good source for inspiration.

2
lib/systems/doubles.nix

@ -33,7 +33,7 @@ let
filterDoubles = f: map parse.doubleFromSystem (lists.filter f allParsed);
in rec {
in {
inherit all;
none = [];

18
lib/systems/examples.nix

@ -24,27 +24,27 @@ rec {
platform = platforms.powernv;
};
sheevaplug = rec {
sheevaplug = {
config = "armv5tel-unknown-linux-gnueabi";
platform = platforms.sheevaplug;
};
raspberryPi = rec {
raspberryPi = {
config = "armv6l-unknown-linux-gnueabihf";
platform = platforms.raspberrypi;
};
armv7l-hf-multiplatform = rec {
armv7l-hf-multiplatform = {
config = "armv7l-unknown-linux-gnueabihf";
platform = platforms.armv7l-hf-multiplatform;
};
aarch64-multiplatform = rec {
aarch64-multiplatform = {
config = "aarch64-unknown-linux-gnu";
platform = platforms.aarch64-multiplatform;
};
armv7a-android-prebuilt = rec {
armv7a-android-prebuilt = {
config = "armv7a-unknown-linux-androideabi";
sdkVer = "24";
ndkVer = "18b";
@ -52,7 +52,7 @@ rec {
useAndroidPrebuilt = true;
};
aarch64-android-prebuilt = rec {
aarch64-android-prebuilt = {
config = "aarch64-unknown-linux-android";
sdkVer = "24";
ndkVer = "18b";
@ -65,17 +65,17 @@ rec {
inherit (platform.gcc) fpu;
};
pogoplug4 = rec {
pogoplug4 = {
config = "armv5tel-unknown-linux-gnueabi";
platform = platforms.pogoplug4;
};
ben-nanonote = rec {
ben-nanonote = {
config = "mipsel-unknown-linux-uclibc";
platform = platforms.ben_nanonote;
};
fuloongminipc = rec {
fuloongminipc = {
config = "mipsel-unknown-linux-gnu";
platform = platforms.fuloong2f_n32;
};

2
lib/systems/parse.nix

@ -403,7 +403,7 @@ rec {
getKernel = name: kernels.${name} or (throw "Unknown kernel: ${name}");
getAbi = name: abis.${name} or (throw "Unknown ABI: ${name}");
parsed = rec {
parsed = {
cpu = getCpu args.cpu;
vendor =
/**/ if args ? vendor then getVendor args.vendor

6
lib/types.nix

@ -107,7 +107,7 @@ rec {
merge = mergeEqualOption;
};
int = mkOptionType rec {
int = mkOptionType {
name = "int";
description = "signed integer";
check = isInt;
@ -136,7 +136,7 @@ rec {
sign = bit: range: ign (0 - (range / 2)) (range / 2 - 1)
"signedInt${toString bit}" "${toString bit} bit signed integer";
in rec {
in {
/* An int with a fixed range.
*
* Example:
@ -172,7 +172,7 @@ rec {
# Alias of u16 for a port number
port = ints.u16;
float = mkOptionType rec {
float = mkOptionType {
name = "float";
description = "floating point number";
check = isFloat;

2
lib/versions.nix

@ -7,7 +7,7 @@ let
in
rec {
{
/* Get the major version string from a string.

2
nixos/lib/make-options-doc/default.nix

@ -126,7 +126,7 @@ let
}
'';
in rec {
in {
inherit optionsNix;
optionsAsciiDoc = lib.concatStringsSep "\n" (lib.mapAttrsToList singleAsciiDoc optionsNix);

2
nixos/lib/utils.nix

@ -1,6 +1,6 @@
pkgs: with pkgs.lib;
rec {
{
# Check whenever fileSystem is needed for boot
fsNeededForBoot = fs: fs.neededForBoot

2
nixos/modules/config/malloc.nix

@ -6,7 +6,7 @@ let
# The set of alternative malloc(3) providers.
providers = {
graphene-hardened = rec {
graphene-hardened = {
libPath = "${pkgs.graphene-hardened-malloc}/lib/libhardened_malloc.so";
description = ''
An allocator designed to mitigate memory corruption attacks, such as

2
nixos/modules/installer/cd-dvd/system-tarball-pc.nix

@ -129,7 +129,7 @@ in
];
nixpkgs.config = {
packageOverrides = p: rec {
packageOverrides = p: {
linux_3_4 = p.linux_3_4.override {
extraConfig = ''
# Enable drivers in kernel for most NICs.

2
nixos/modules/installer/netboot/netboot.nix

@ -18,7 +18,7 @@ with lib;
};
config = rec {
config = {
# Don't build the GRUB menu builder script, since we don't need it
# here and it causes a cyclic dependency.
boot.loader.grub.enable = false;

2
nixos/modules/programs/firejail.nix

@ -5,7 +5,7 @@ with lib;
let
cfg = config.programs.firejail;
wrappedBins = pkgs.stdenv.mkDerivation rec {
wrappedBins = pkgs.stdenv.mkDerivation {
name = "firejail-wrapped-binaries";
nativeBuildInputs = with pkgs; [ makeWrapper ];
buildCommand = ''

2
nixos/modules/services/cluster/kubernetes/default.nix

@ -261,7 +261,7 @@ in {
before = [ "kubernetes.target" ];
};
systemd.services.kube-control-plane-online = rec {
systemd.services.kube-control-plane-online = {
description = "Kubernetes control plane is online";
wantedBy = [ "kube-control-plane-online.target" ];
after = [ "kube-scheduler.service" "kube-controller-manager.service" ];

2
nixos/modules/services/continuous-integration/hydra/default.nix

@ -43,7 +43,7 @@ in
###### interface
options = {
services.hydra = rec {
services.hydra = {
enable = mkOption {
type = types.bool;

2
nixos/modules/services/hardware/sane_extra_backends/brscan4_etc_files.nix

@ -33,7 +33,7 @@ let
addAllNetDev = xs: concatStringsSep "\n" (map addNetDev xs);
in
stdenv.mkDerivation rec {
stdenv.mkDerivation {
name = "brscan4-etc-files-0.4.3-3";
src = "${brscan4}/opt/brother/scanner/brscan4";

4
nixos/modules/services/misc/gitlab.nix

@ -140,7 +140,7 @@ let
RAILS_ENV = "production";
};
gitlab-rake = pkgs.stdenv.mkDerivation rec {
gitlab-rake = pkgs.stdenv.mkDerivation {
name = "gitlab-rake";
buildInputs = [ pkgs.makeWrapper ];
dontBuild = true;
@ -155,7 +155,7 @@ let
'';
};
gitlab-rails = pkgs.stdenv.mkDerivation rec {
gitlab-rails = pkgs.stdenv.mkDerivation {
name = "gitlab-rails";
buildInputs = [ pkgs.makeWrapper ];
dontBuild = true;

2
nixos/modules/services/misc/pykms.nix

@ -9,7 +9,7 @@ in {
meta.maintainers = with lib.maintainers; [ peterhoeg ];
options = {
services.pykms = rec {
services.pykms = {
enable = mkOption {
type = types.bool;
default = false;

2
nixos/modules/services/misc/zoneminder.nix

@ -312,7 +312,7 @@ in {
};
systemd.services = {
zoneminder = with pkgs; rec {
zoneminder = with pkgs; {
inherit (zoneminder.meta) description;
documentation = [ "https://zoneminder.readthedocs.org/en/latest/" ];
path = [

2
nixos/modules/services/network-filesystems/openafs/lib.nix

@ -3,7 +3,7 @@
let
inherit (lib) concatStringsSep mkOption types;
in rec {
in {
mkCellServDB = cellName: db: ''
>${cellName}

2
nixos/modules/services/networking/kippo.nix

@ -11,7 +11,7 @@ with lib;
let
cfg = config.services.kippo;
in
rec {
{
options = {
services.kippo = {
enable = mkOption {

2
nixos/modules/services/web-apps/frab.nix

@ -19,7 +19,7 @@ let
RAILS_SERVE_STATIC_FILES = "1";
} // cfg.extraEnvironment;
frab-rake = pkgs.stdenv.mkDerivation rec {
frab-rake = pkgs.stdenv.mkDerivation {
name = "frab-rake";
buildInputs = [ package.env pkgs.makeWrapper ];
phases = "installPhase fixupPhase";

2
nixos/modules/services/web-apps/wordpress.nix

@ -133,7 +133,7 @@ let
'';
};
database = rec {
database = {
host = mkOption {
type = types.str;
default = "localhost";

2
nixos/tests/borgbackup.nix

@ -44,7 +44,7 @@ in {
client = { ... }: {
services.borgbackup.jobs = {
local = rec {
local = {
paths = dataDir;
repo = localRepo;
preHook = ''

2
nixos/tests/ceph.nix

@ -1,4 +1,4 @@
import ./make-test.nix ({pkgs, ...}: rec {
import ./make-test.nix ({pkgs, ...}: {
name = "All-in-one-basic-ceph-cluster";
meta = with pkgs.stdenv.lib.maintainers; {
maintainers = [ lejonet ];

3
nixos/tests/cjdns.nix

@ -23,8 +23,7 @@ import ./make-test.nix ({ pkgs, ...} : {
maintainers = [ ehmry ];
};
nodes = rec
{ # Alice finds peers over over ETHInterface.
nodes = { # Alice finds peers over over ETHInterface.
alice =
{ ... }:
{ imports = [ basicConfig ];

2
nixos/tests/cockroachdb.nix

@ -100,7 +100,7 @@ in import ./make-test.nix ({ pkgs, ...} : {
meta.maintainers = with pkgs.stdenv.lib.maintainers;
[ thoughtpolice ];
nodes = rec {
nodes = {
node1 = makeNode "country=us,region=east,dc=1" "192.168.1.1" null;
node2 = makeNode "country=us,region=west,dc=2b" "192.168.1.2" "192.168.1.1";
node3 = makeNode "country=eu,region=west,dc=2" "192.168.1.3" "192.168.1.1";

2
nixos/tests/containers-reloadable.nix

@ -1,6 +1,6 @@
import ./make-test.nix ({ pkgs, lib, ...} :
let
client_base = rec {
client_base = {
containers.test1 = {
autoStart = true;

2
nixos/tests/containers-restart_networking.nix

@ -1,7 +1,7 @@
# Test for NixOS' container support.
let
client_base = rec {
client_base = {
networking.firewall.enable = false;
containers.webserver = {

2
nixos/tests/flannel.nix

@ -1,4 +1,4 @@
import ./make-test.nix ({ pkgs, ...} : rec {
import ./make-test.nix ({ pkgs, ...} : {
name = "flannel";
meta = with pkgs.stdenv.lib.maintainers; {

2
nixos/tests/hardened.nix

@ -28,7 +28,7 @@ import ./make-test.nix ({ pkgs, ...} : {
testScript =
let
hardened-malloc-tests = pkgs.stdenv.mkDerivation rec {
hardened-malloc-tests = pkgs.stdenv.mkDerivation {
name = "hardened-malloc-tests-${pkgs.graphene-hardened-malloc.version}";
src = pkgs.graphene-hardened-malloc.src;
buildPhase = ''

2
nixos/tests/initrd-network-ssh/default.nix

@ -6,7 +6,7 @@ import ../make-test.nix ({ lib, ... }:
maintainers = [ willibutz ];
};
nodes = with lib; rec {
nodes = with lib; {
server =
{ config, ... }:
{

2
nixos/tests/jackett.nix

@ -2,7 +2,7 @@ import ./make-test.nix ({ lib, ... }:
with lib;
rec {
{
name = "jackett";
meta.maintainers = with maintainers; [ etu ];

2
nixos/tests/lidarr.nix

@ -2,7 +2,7 @@ import ./make-test.nix ({ lib, ... }:
with lib;
rec {
{
name = "lidarr";
meta.maintainers = with maintainers; [ etu ];

2
nixos/tests/mosquitto.nix

@ -16,7 +16,7 @@ let
"-t ${topic}"
];
in rec {
in {
name = "mosquitto";
meta = with pkgs.stdenv.lib; {
maintainers = with maintainers; [ peterhoeg ];

2
nixos/tests/quake3.nix

@ -4,7 +4,7 @@ let
# Build Quake with coverage instrumentation.
overrides = pkgs:
rec {
{
quake3game = pkgs.quake3game.override (args: {
stdenv = pkgs.stdenvAdapters.addCoverageInstrumentation args.stdenv;
});

2
nixos/tests/radarr.nix

@ -2,7 +2,7 @@ import ./make-test.nix ({ lib, ... }:
with lib;
rec {
{
name = "radarr";
meta.maintainers = with maintainers; [ etu ];

2
nixos/tests/sonarr.nix

@ -2,7 +2,7 @@ import ./make-test.nix ({ lib, ... }:
with lib;
rec {
{
name = "sonarr";
meta.maintainers = with maintainers; [ etu ];

2
pkgs/applications/altcoins/parity/parity.nix

@ -14,7 +14,7 @@
, perl
}:
rustPlatform.buildRustPackage rec {
rustPlatform.buildRustPackage {
pname = "parity";
inherit version;
inherit cargoSha256;

2
pkgs/applications/audio/a2jmidid/default.nix

@ -4,7 +4,7 @@
let
inherit (python2Packages) python dbus-python;
in stdenv.mkDerivation rec {
in stdenv.mkDerivation {
pname = "a2jmidid";
version = "8";

2
pkgs/applications/audio/cantata/default.nix

@ -35,7 +35,7 @@ let
withUdisks = (withTaglib && withDevices);
in mkDerivation rec {
in mkDerivation {
name = "${pname}-${version}";
src = fetchFromGitHub {

2
pkgs/applications/audio/caudec/default.nix

@ -4,7 +4,7 @@ let
version = "1.7.5";
in
stdenv.mkDerivation rec {
stdenv.mkDerivation {
pname = "caudec";
inherit version;

2
pkgs/applications/audio/cmusfm/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchFromGitHub, autoreconfHook, pkgconfig, curl, libnotify, gdk-pixbuf }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
version = "2018-10-11";
pname = "cmusfm-unstable";
src = fetchFromGitHub {

2
pkgs/applications/audio/csound/csound-manual/default.nix

@ -4,7 +4,7 @@
libxslt
}:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
pname = "csound-manual";
version = "unstable-2019-02-22";

2
pkgs/applications/audio/deadbeef/plugins/lyricbar.nix

@ -1,6 +1,6 @@
{ stdenv, fetchFromGitHub, pkgconfig, deadbeef, gtkmm3, libxmlxx3 }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
pname = "deadbeef-lyricbar-plugin";
version = "unstable-2019-01-29";

2
pkgs/applications/audio/dirt/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchFromGitHub, libsndfile, libsamplerate, liblo, libjack2 }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
name = "dirt-2018-01-01";
src = fetchFromGitHub {
repo = "Dirt";

2
pkgs/applications/audio/faust/faustlive.nix

@ -3,7 +3,7 @@
, bc, coreutils, which
}:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
pname = "faustlive";
version = "2017-12-05";
src = fetchFromGitHub {

2
pkgs/applications/audio/fluidsynth/default.nix

@ -19,7 +19,7 @@ in
with versionMap.${version};
stdenv.mkDerivation rec {
stdenv.mkDerivation {
name = "fluidsynth-${fluidsynthVersion}";
version = fluidsynthVersion;

2
pkgs/applications/audio/fmsynth/default.nix

@ -1,5 +1,5 @@
{ stdenv, fetchFromGitHub, gtkmm2, lv2, lvtk, pkgconfig }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
pname = "fmsynth-unstable";
version = "2015-02-07";
src = fetchFromGitHub {

2
pkgs/applications/audio/foo-yc20/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchFromGitHub, libjack2, gtk2, lv2, faust, pkgconfig }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
version = "git-2015-05-21";
pname = "foo-yc20";
src = fetchFromGitHub {

2
pkgs/applications/audio/gnome-podcasts/default.nix

@ -3,7 +3,7 @@
# TODO: build from git for easier updates
# rustPlatform.buildRustPackage rec {
stdenv.mkDerivation rec {
stdenv.mkDerivation {
version = "0.4.6";
pname = "gnome-podcasts";

2
pkgs/applications/audio/gradio/default.nix

@ -18,7 +18,7 @@
let
version = "7.2";
in stdenv.mkDerivation rec {
in stdenv.mkDerivation {
pname = "gradio";
inherit version;

2
pkgs/applications/audio/helm/default.nix

@ -1,7 +1,7 @@
{ stdenv, fetchFromGitHub , xorg, freetype, alsaLib, curl, libjack2
, lv2, pkgconfig, libGLU_combined }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
version = "0.9.0";
pname = "helm";

2
pkgs/applications/audio/iannix/default.nix

@ -1,7 +1,7 @@
{ stdenv, fetchFromGitHub, alsaLib, pkgconfig, qtbase, qtscript, qmake
}:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
pname = "iannix";
version = "2016-01-31";
src = fetchFromGitHub {

2
pkgs/applications/audio/jackmix/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, pkgconfig, scons, qt4, lash, libjack2, jack ? libjack2 }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
name = "jackmix-0.5.2";
src = fetchurl {
url = https://github.com/kampfschlaefer/jackmix/archive/v0.5.2.tar.gz;

2
pkgs/applications/audio/lv2bm/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchFromGitHub, glib, lilv, lv2, pkgconfig, serd, sord, sratom }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
pname = "lv2bm";
version = "git-2015-11-29";

2
pkgs/applications/audio/mod-distortion/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchFromGitHub, lv2 }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
pname = "mod-distortion-git";
version = "2016-08-19";

2
pkgs/applications/audio/muse/default.nix

@ -16,7 +16,7 @@
, gitAndTools
}:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
pname = "muse-sequencer";
version = "3.1pre1";

2
pkgs/applications/audio/musly/default.nix

@ -1,5 +1,5 @@
{ stdenv, fetchFromGitHub, cmake, eigen, libav_all }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
pname = "musly";
version = "unstable-2017-04-26";
src = fetchFromGitHub {

2
pkgs/applications/audio/non/default.nix

@ -2,7 +2,7 @@
, libsndfile, ladspaH, liblrdf, liblo, libsigcxx, wafHook
}:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
pname = "non";
version = "2018-02-15";
src = fetchFromGitHub {

2
pkgs/applications/audio/nova-filters/default.nix

@ -1,6 +1,6 @@
{stdenv, fetchurl, sconsPackages, boost, ladspaH, pkgconfig }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
version = "0.2-2";
pname = "nova-filters";

2
pkgs/applications/audio/openmpt123/default.nix

@ -3,7 +3,7 @@
let
version = "0.4.1";
in stdenv.mkDerivation rec {
in stdenv.mkDerivation {
pname = "openmpt123";
inherit version;

2
pkgs/applications/audio/patchage/default.nix

@ -2,7 +2,7 @@
, gtkmm2, libjack2, pkgconfig, python2, wafHook
}:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
pname = "patchage";
version = "1.0.1";
src = fetchsvn {

2
pkgs/applications/audio/pd-plugins/helmholtz/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, unzip, puredata }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
name = "helmholtz";
src = fetchurl {

2
pkgs/applications/audio/pd-plugins/mrpeach/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, puredata }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
pname = "mrpeach";
version = "1.1";

2
pkgs/applications/audio/pianobooster/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, alsaLib, cmake, libGLU_combined, makeWrapper, qt4 }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
pname = "pianobooster";
version = "0.6.4b";

2
pkgs/applications/audio/plugin-torture/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchFromGitHub, boost, ladspaH, lilv, lv2, pkgconfig, serd, sord, sratom }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
pname = "plugin-torture";
version = "2016-07-25";

2
pkgs/applications/audio/pulseaudio-dlna/default.nix

@ -17,7 +17,7 @@ assert vorbisSupport -> vorbisTools != null;
let
zeroconf = pythonPackages.callPackage ./zeroconf.nix { };
in pythonPackages.buildPythonApplication rec {
in pythonPackages.buildPythonApplication {
pname = "pulseaudio-dlna";
version = "2017-11-01";

2
pkgs/applications/audio/rhvoice/default.nix

@ -3,7 +3,7 @@
let
version = "unstable-2018-02-10";
in stdenv.mkDerivation rec {
in stdenv.mkDerivation {
pname = "rhvoice";
inherit version;

2
pkgs/applications/audio/shntool/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, flac }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
version = "3.0.10";
pname = "shntool";

2
pkgs/applications/audio/soundscape-renderer/default.nix

@ -14,7 +14,7 @@
, libGLU_combined # Needed because help2man basically does a ./ssr-binaural --help and ssr-binaural needs libGL
}:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
pname = "soundscape-renderer-unstable";
version = "2016-11-03";

4
pkgs/applications/audio/speech-denoiser/default.nix

@ -8,7 +8,7 @@ let
sha256 = "189l6lz8sz5vr6bjyzgcsrvksl1w6crqsg0q65r94b5yjsmjnpr4";
};
rnnoise-nu = stdenv.mkDerivation rec {
rnnoise-nu = stdenv.mkDerivation {
pname = "rnnoise-nu";
version = "unstable-07-10-2019";
src = speech-denoiser-src;
@ -18,7 +18,7 @@ let
installTargets = [ "install-rnnoise-nu" ];
};
in
stdenv.mkDerivation rec {
stdenv.mkDerivation {
pname = "speech-denoiser";
version = "unstable-07-10-2019";

2
pkgs/applications/audio/spotifywm/default.nix

@ -1,5 +1,5 @@
{ stdenv, fetchFromGitHub, spotify, xorg, runtimeShell }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
pname = "spotifywm-unstable";
version = "2016-11-28";

2
pkgs/applications/audio/svox/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchgit }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
pname = "svox";
version = "2017-07-18";

2
pkgs/applications/audio/traverso/default.nix

@ -2,7 +2,7 @@
, alsaLib, fftw, flac, lame, libjack2, libmad, libpulseaudio
, libsamplerate, libsndfile, libvorbis, portaudio, qtbase, wavpack
}:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
pname = "traverso";
version = "0.49.6";

2
pkgs/applications/audio/uade123/default.nix

@ -2,7 +2,7 @@
let
version = "2.13";
in stdenv.mkDerivation rec {
in stdenv.mkDerivation {
pname = "uade123";
inherit version;
src = fetchurl {

2
pkgs/applications/audio/zam-plugins/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchgit , boost, libX11, libGLU_combined, liblo, libjack2, ladspaH, lv2, pkgconfig, rubberband, libsndfile, fftwFloat, libsamplerate }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
pname = "zam-plugins";
version = "3.11";

2
pkgs/applications/backup/areca/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, ant, jre, jdk, swt, acl, attr }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
name = "areca-7.5";
src = fetchurl {

2
pkgs/applications/display-managers/lightdm-enso-os-greeter/default.nix

@ -2,7 +2,7 @@
, dbus, pcre, epoxy, libXdmcp, at-spi2-core, libxklavier, libxkbcommon, libpthreadstubs
, gtk3, vala, cmake, libgee, libX11, lightdm, gdk-pixbuf, clutter-gtk }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
version = "0.2.1";
pname = "lightdm-enso-os-greeter";

2
pkgs/applications/display-managers/sddm/default.nix

@ -6,7 +6,7 @@
let
version = "0.18.1";
in mkDerivation rec {
in mkDerivation {
pname = "sddm";
inherit version;

2
pkgs/applications/editors/android-studio/default.nix

@ -18,7 +18,7 @@ let
build = "192.5807797";
sha256Hash = "1l47miiyd8z7v0hbvda06953pp9ilyrsma83gxqx35ghnc0n7g81";
};
in rec {
in {
# Attributes are named by their corresponding release channels
stable = mkStudio (stableVersion // {

2
pkgs/applications/editors/aseprite/skia.nix

@ -7,7 +7,7 @@ let
# skia-deps.nix is generated by: ./skia-make-deps.sh 'angle2|dng_sdk|piex|sfntly'
depSrcs = import ./skia-deps.nix { inherit fetchgit; };
in
stdenv.mkDerivation rec {
stdenv.mkDerivation {
name = "skia-aseprite-m71";
src = fetchFromGitHub {

2
pkgs/applications/editors/edit/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchgit, unzip, pkgconfig, ncurses, libX11, libXft, cwebbin }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
pname = "edit-nightly";
version = "20160425";

2
pkgs/applications/editors/elvis/default.nix

@ -1,6 +1,6 @@
{ fetchurl, fetchpatch, stdenv, ncurses }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
name = "elvis-2.2_0";
src = fetchurl {

2
pkgs/applications/editors/emacs-modes/cedille/default.nix

@ -1,6 +1,6 @@
{ stdenv, cedille, emacs }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
pname = "cedille-mode";
version = cedille.version;

2
pkgs/applications/editors/emacs-modes/coffee/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchgit, emacs }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
name = "coffee-mode-0.4.1";
src = fetchgit {

2
pkgs/applications/editors/emacs-modes/color-theme-solarized/default.nix

@ -2,7 +2,7 @@
let
commit = "412713a0fcedd520d208a7b783fea03d710bcc61";
in
stdenv.mkDerivation rec {
stdenv.mkDerivation {
name = "color-theme-solarized-1.0.0";
src = fetchzip {

2
pkgs/applications/editors/emacs-modes/emacs-w3m/default.nix

@ -1,7 +1,7 @@
{ fetchcvs, stdenv, emacs, w3m, imagemagick, texinfo, autoreconfHook }:
let date = "2013-03-21"; in
stdenv.mkDerivation rec {
stdenv.mkDerivation {
name = "emacs-w3m-cvs${date}";
# Get the source from CVS because the previous release (1.4.4) is old and

2
pkgs/applications/editors/emacs-modes/flymake-cursor/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, emacs }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
name = "flymake-cursor-0.1.5";
src = fetchurl {

2
pkgs/applications/editors/emacs-modes/gh/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchgit, emacs, pcache, logito }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
name = "gh-0.5.3";
src = fetchgit {

2
pkgs/applications/editors/emacs-modes/gist/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchgit, emacs, gh, pcache, logito }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
name = "gist-1.0";
src = fetchgit {

2
pkgs/applications/editors/emacs-modes/logito/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchgit, emacs }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
name = "logito-0.1";
src = fetchgit {

2
pkgs/applications/editors/emacs-modes/lorem-ipsum/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchurl, emacs }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
name = "lorem-ipsum-0.1";
src = fetchurl {

6
pkgs/applications/editors/emacs-modes/manual-packages.nix

@ -59,7 +59,7 @@
font-lock-plus = callPackage ./font-lock-plus { };
ghc-mod = melpaBuild rec {
ghc-mod = melpaBuild {
pname = "ghc";
version = external.ghc-mod.version;
src = external.ghc-mod.src;
@ -75,7 +75,7 @@
};
};
haskell-unicode-input-method = melpaBuild rec {
haskell-unicode-input-method = melpaBuild {
pname = "emacs-haskell-unicode-input-method";
version = "20110905.2307";
src = pkgs.fetchFromGitHub {
@ -104,7 +104,7 @@
icicles = callPackage ./icicles { };
rtags = melpaBuild rec {
rtags = melpaBuild {
inherit (external.rtags) version src meta;
pname = "rtags";

2
pkgs/applications/editors/emacs-modes/melpa-packages.nix

@ -458,7 +458,7 @@ env NIXPKGS_ALLOW_BROKEN=1 nix-instantiate --show-trace ../../../../ -A emacsPac
};
});
in pkgs.stdenv.mkDerivation rec {
in pkgs.stdenv.mkDerivation {
inherit (super.vterm) name version src;
nativeBuildInputs = [ pkgs.cmake ];

2
pkgs/applications/editors/emacs-modes/metaweblog/default.nix

@ -1,6 +1,6 @@
{ stdenv, fetchgit, emacs, xmlRpc }:
stdenv.mkDerivation rec {
stdenv.mkDerivation {
name = "metaweblog-0.1";
src = fetchgit {