You cannot select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
18 lines
454 B
Nix
18 lines
454 B
Nix
{ pkgs ? import <nixpkgs> {}
|
|
}:
|
|
with pkgs;
|
|
let
|
|
yammat = haskellPackages:
|
|
haskellPackages.callPackage <yammat> {};
|
|
ghcVersions =
|
|
builtins.filter (p:
|
|
p == "ghcHEAD" || builtins.match "ghc[[:digit:]]+" p != null
|
|
) (builtins.attrNames haskell.packages);
|
|
in
|
|
|
|
builtins.listToAttrs
|
|
(map (ghcVersion: {
|
|
name = "yammat-${ghcVersion}";
|
|
value = lib.hydraJob (yammat (builtins.getAttr ghcVersion haskell.packages));
|
|
}) ghcVersions)
|