You cannot select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
15 lines
459 B
Nix
15 lines
459 B
Nix
{ pkgs ? import <nixpkgs> {}
|
|
}:
|
|
let
|
|
ghcVersions =
|
|
builtins.filter (p:
|
|
p == "ghcHEAD" || builtins.match "ghc[[:digit:]]+" p != null
|
|
) (builtins.attrNames pkgs.haskell.packages);
|
|
mateamt = haskellPackages: haskellPackages.callPackage <mateamt> {};
|
|
in
|
|
builtins.listToAttrs
|
|
(map (ghcVersion: {
|
|
name = "mateamter-${ghcVersion}";
|
|
value = pkgs.lib.hydraJob (mateamt (builtins.getAttr ghcVersion pkgs.haskell.packages));
|
|
}) ghcVersions)
|